Win10 - Updateproblem

blackdeath

GROSS!ARTIG?
Gab es bei den letzten Win10 Updates Probleme mit Raid oder anderes?

Ein Freund hat beim Systemstart folgende Probleme:
Win10 Oberfläche wird geladen, Fehlermeldung "Desktop kann nicht angezeigt werden" nur der Papierkorb taucht auf
Aufruf vom Datei-Explorer, da bleibt das Fenster leer
Gerätemanager werden keine Probleme angezeigt
Der abgesicherte Modus ist nicht verfügbar.
Das Win10-System liegt auf einer SSD und die Daten auf einem Raid-1 wobei das Raid in der Datenträgerverwaltung nicht auftaucht im oberen Teil, im unteren Teil als "nicht zugeordnet" angezeigt wird.
Win10 20H2

Der Rechner lief eine Zeitlang nicht, gestern wurde dann von einem USB Stick eine Filmdatei kopiert und dabei ein Update installiert. Danach lief das System normal, später normal herunter gefahren.
Heute sollte das System normal gestartet werden und dann passierte eben dieser Desktop Fehler und das fehlende Raid.

Ich kann da nicht so vorbei fahren, ist also reiner Telefonsupport, weiss jemand was das für ein Fehler sein könnte?
 

EchtAtze

Bekannter Mitglied
Ich lese immer hier bei Günni in den diversen monatlichen Windows-/Office-Update-Beiträgen nach (auch in den Kommentaren) ob es Probleme gibt, bevor ich sie einspiele.
Soweit ich mich erinnere kam mir so etwas nicht unter.
 

sPIfF c99

fearless spaceman
allenfalls hilft das:

ctrl-alt-del

Taskmanager öffnen
Mehr Details muss aktiv sein

File / Run
msconfig.exe

Boot Tab öffnen
Safe Boot aktivieren
neu starten

ist Safe Boot geladen, wieder msconfig öffnen
und Safe Boot wieder deaktvieren
und wieder neu starten
 

eumel_1

rüpelhafter Bierhippie
Wenn das Raid von einem Hardware Raidcontroller gesteuert wird, sieht es Windows nicht, das ist normal so.
Das einzige was Windows sieht, ist der Controller selber, die gespiegelten Platten tauchen nur als eine einzige auf, die echten zwei Platten siehst du nur im BIOS des Controllers, in das Menü kommst du wenn du Windows sagst:
Neu starten
und dann entsprechend des Controllertyps beim Start die richtige Tastenkombination, bei Adaptec Controllern ist das CTRL - ALT - A.

EDIT:
Google sagt folgendes dazu:
Zugriff auf das RAID-BIOS im UEFI-Modus
Wenn diese Systeme im UEFI-BIOS-Modus konfiguriert sind, wird über das F12-Startmenü auf das RAID-Setup zugegriffen.
 

blackdeath

GROSS!ARTIG?
Windows zeigt im Datenträgermanager, nur eine Platte an, das war auch vorher so.
Der Manager ist ja zweigeteilt, oben die Laufwerke wie sie auch später im Explorer auftauchen und unten die physischen Laufwerke mit den Partitionen.
Das Raid-1, aus 2 HDD, wird als eine Platte unten korrekt angezeigt, nur halt als inaktiv.
 

eumel_1

rüpelhafter Bierhippie
Inaktiv, weil nicht von Windows verwaltet? Hab grad kein Hardware Raid hier um das zu prüfen, damit muss ich mich nur auf Arbeit rumärgern, kann ich dir in 2 Wochen sagen ob das normal ist.
Du solltest einfach mal den Status checken, zuerst in Windows unter
Festplattenpartitionen erstellen und formatieren
und da das wohl kaum etwas aussagt, dann direkt im Raidcontroller.
Je nachdem, welchen Controller du im Einsatz hast, kann das auch die Controllersoftware. Bei Adaptec sollte man auch im Storage Manager Auskunft erhalten.
(Hast ja immer noch nicht verraten, welchen Controller du verwendest - oder ist es gar nur ein Softwareraid? Dann reicht die Windows Auskunft im Festplattenpartitionen und ... .

PS: für "Ich kann da nicht so vorbei fahren" gibt es Team Viewer Quick Support, die Exe bei deinem Kumpel ausführen lassen, dir die Logindaten geben lassen und du kannst bequem von deinem Rechner seinen Rechner fernsteuern.
PPS: Hier der Link zur Webseite des Downloads: https://www.teamviewer.com/de/info/quicksupport/

Ich packe auf jeden Rechner den ich betreue einen Ordner "Install" auf das D-drive, da drin u.a. der TeamViewerQS und eine Verknüpfung zum Programm auf den Desktop, so kann jeder meiner Patienten im Zweifelsfall anrufen und schnell kompetente Hilfe bekommen.
 
Zuletzt bearbeitet:

blackdeath

GROSS!ARTIG?
sorry, die Information hatte ich bis eben selbst nicht

Das ist ein Raid über Mainboardchipsatz, also SoftwareRAID.

Also es wurde nun das System auf einen Wiederherstellungspunkt zurück gesetzt, beim Desktop tauchten kurz alle alten Symbole wieder auf, trotzdem die Meldung der Desktop wäre nicht verfügbar, nach Klick auf OK verschwinden die Symbole wieder und RAID ist auch nicht verfügbar.

Also das Update war es dann wohl nicht.
 

eumel_1

rüpelhafter Bierhippie
Ich würde das Raid checken, inaktiv bei Raid 1 bedeutet dass eine der Platten fehlt.
Kann ganz einfach Stromversorgung oder Datenleitung sein, also einfach mal runterfahren, bei Standard (IDE, SATA, SAS) jeweils beide Kabel abziehen und wieder anstecken. Bei mSATA oder M.2 mal die Schraube lösen, das Modul kurz entnehmen und wieder in den Sockel rein, dann erneut testen. Beim Bootscreen bzw. im Bios sollten die Platten alle sichtbar sein. Bei einigen BIOSsen kann man auch die Smart Werte sehen.
 

blackdeath

GROSS!ARTIG?
Sorry, der Typ hatte erst eine andere Aufgabe gemacht und sich wieder nun wieder gemeldet.

Heute konnten wir in knapp 3 Stunden ein paar mehr Sachen durchspielen. Also seine System SSD war wohl hinüber und er musste Win10 neu installieren.

Das Mainboard ist ein Gigabyte GA-z68x-UD3H-B3, Win10 konnte man auf eine neue SSD problemlos installieren, nur kann man nun keine passenden Treiber für den Mainboard Raid Controller installieren, weil die Plattform nicht unterstützt wird. Der Wechsel von Win7 auf Win10 funktionierte damals problemlos und das RAID funktionierte´dort auch, nach einer Komplettneuinstallation gibt es keine Treiber mehr.

Intel® Rapid Storage Technology hatte ich sowohl einen älteren Treiber und auch einen aktuellen probiert, keine Installation möglich. Dann gab es eine Möglichkeit über den Microsoft Store einen Intel Storage Treiber zu installieren, der ging auch, anschließend tauchte nur der RAID Controller als fehlerhaft im Gerätemanager auf.

Dieser Treiber:

Win10 Pro ist 21H1, vorher war es ein älteres Win10 Pro, das könnte natürlich nun das Problem sein.
 

Rubb

Rover
Welche Einstellungen hat denn das Windows-Update, eigentlich sollte es da die nötigen Treiber mit der OS-Update funktion von Seiten MS geben, ohne die Treiber verzweifelt beim Hersteller suchen zu müssen.

Dieser folgende Hinweis mit "WSUSoffline.net" geht allerdings nur bei den Reiferen Editionen bis "Win10 1909":
Installiere selbst immer mit "WSUSoffline.net" die (mit einem Anderen, laufenden Rechner heruntergeladenen Updates, bevor ich ins Inet gehe um fehlende Dateien von Seiten MS mit der OS-Update funktion zu erhalten)

(bei z.B. dieser "Win10 21H1" ist doch ein Internet-Update nötig!)

edit//
hier noch ein Statement von Entwickler-Seite

https://forums.wsusoffline.net/viewtopic.php?f=6&t=172
Das Hauptziel von WSUS Offline Update liegt darin, frisch installierte Windows-Computer auf schnelle und sichere Weise auf einen Patch-Stand zu bringen, der die sichere Verbindung mit dem Internet erlaubt. Von diesem Standpunkt aus ist sogar der Office-Teil des WSUS Offline Update ein "Schmankerl".
 

SkAvEnGeR

Master of Tools
@blackdeath
Sind die BIOS-Settings auch korrekt eingestellt, um RAID zu aktivieren?
2021-09-20 11_59_42-Integrated Peripherals - Gigabyte GA-Z68X-UD3H-B3 User Manual [Page 50] _ ...png
(weil die Gigabyte-Seite aktuell Probleme macht und sich dort das Handbuch nicht laden lässt.)

Fehlende Treiber behebe ICH immer mit Drivermax.com - habe da die Vollversion gekauft und quasi noch nie Probleme
Dann kann/muss man das Gigabyte XHD Utility laden - mit dem man dann das RAID konfigurieren kann
 

edvfuzzi

RumPichler
Kann über "Drivermax" auch (fast) nur Positives berichten. Wenn ich irgendeinen älteren Rechner ganz neu aufsetze, zu dem mir gar keine (auch keine Netzwerk-) Treiber vorliegen stöpsele ich als erstes eine externe WLAN-Lösung dran (ich liebe meinen alten "Alfa-USB) und starte das Programm dazu vom USB-Stick. Schon habe ich zumindest einen Internet-Zugang.
Mit der kostenlosen Variante von "Drivermax" kann man, wenn ich mich recht erinnere, immer wenigstens EINEN der zum Download angebotenen Treiber herunterladen.
Mit der Vollversion (kann ich wirklich empfehlen) KANN man alle für den jeweiligen Rechner als updatebedürftig angezeigten Treiber in einem Rutsch herunterladen und dann auch automatisch - einen nach dem anderen - installieren lassen. Das würde ich wegen schlechter Erfahrungen damit allerdings nicht empfehlen. Ab und zu kam es bei mir vor, dass einer von mehreren Treibern beim nächsten Booten quergeschossen und den Bootvorgang behindert hatte - und dann ging die Sucherei los . . . - also lieber immer nur 2-3 Treiber installieren und dann erstmal testen!

Also versuch' doch zunächst mal, mit der Free-Version von Drivermax, ob er bei seinem Suchlauf einen Treiber für Dein Problemkind findet und den EINEN kannst Du ja dann mal testweise installieren.

Viel Glück!!! :yo
 

blackdeath

GROSS!ARTIG?
Das ist ja eine Telefonsupport Geschichte, aber ich hatte die Downloadseiten zum Mainboard und Chipsatz ..... auch so aufgerufen.

Laut der Intel Downloadseite gibt es in Absprache mit Microsoft nur noch eine Art von Downloads und zwar über die MS Store-Seite und mit Drivermax klappt das dann trotzdem?

Ich gebe das mal weiter, danke aber schon mal für die weiteren Hinweise.
 

SkAvEnGeR

Master of Tools
Wie gesagt, Drivermax ist ein externer Treiber-Updater mit einer sehr umfangreichen Treiber-Datenbank - und vollkommen unabhängig von MS oder anderen Herstellern!
Das Tool analysiert deine Hardware und die vorhandenen/fehlenden Treiber und bietet dir dann Updates für bestehende oder fehlende Treiber an.
Grundvoraussetzung ist natürlich, dass das BIOS korrekt eingestellt wurde.

Hast du schonmal versucht, den originalen RAID-Treiber von der Gigabyte-Seite zu nehmen, der eigentlich für Win7 x64 gedacht ist?
Oft konnte ich "alte" Win7 Treiber problemlos auch unter Win10 installieren.
 

eumel_1

rüpelhafter Bierhippie
Win7x64 Treiber funktionieren unter Windows 10, genauso mache ich das mit den Treibern für mein Softwareoszilloskop.

Zur Treibersuche benutze ich Driver Easy Professional, klappt auch sehr gut.

Aber @SkAvEnGeR erwähnte die BIOS-Einstellungen, stimmen diese nicht, kannst du gar nicht erst ein Softwareraid konfigurieren.
Diesen Punkt würde ich zuerst überprüfen!
 

blackdeath

GROSS!ARTIG?
Der Raid Controller wird als fehlerhaft im Gerätemanager angezeigt, da ja das Treiberpaket sowohl von Gigabyte wie auch von Intel nicht angenommen wurde.

"Die Plattform wird nicht unterstützt" kam als Fehlermeldung.

Das Raid funktionierte ja vorher, sowohl unter Win7 und dann Win10, dann kam dieses Update von MS, dann stieg die System SSD aus und danach wurde das System auf eine neue SSD eingespielt.

Am BIOS selbst wurde dabei nichts verändert.
 

SkAvEnGeR

Master of Tools
kann ja sein, dass der Controller auf dem MoBo nun "einen weg" hat und daher nicht mehr ordnungsgemäß funktioniert.
Angesichts des Alters des Mainboards gar nicht so abwägig.

Also bei diesem Aufwand und Alter ...

entweder RAID-Steckkarte einbauen oder den PC gleich ersetzen (sofern möglich)
 

blackdeath

GROSS!ARTIG?
Ja, hatte das auch angedacht, aber zwecks Geldmangel erst mal verworfen, aber heute kam ihm dann selbst der Gedanke das Mainboard zu ersetzen.

Da kommt dann eine andere Frage, das war ja ein RAID1 Verbund, also gespiegelte Daten auf den beiden Platten, kann man dabei eine Platte an einen normalen SATA Anschluss klemmen und einfach den Platteninhalt sichern, oder muss zwingend wieder über einen RAID Controller der Inhalt ausgelesen werden?

Im Anschluss Rechner (neues MB) soll kein neues (altes) RAID eingebaut werden.
 

Dorwyn

Bekanntes Mitglied
kann man dabei eine Platte an einen normalen SATA Anschluss klemmen und einfach den Platteninhalt sichern, oder muss zwingend wieder über einen RAID Controller der Inhalt ausgelesen werden?
Wenn es RAID 1 war, dann kann man eine der beiden Platten (sprich eine die noch funktioniert) einfach über SATA anschließen und die Daten darauf wegsichern. Ginge auch über einen externen USB zu SATA Anschluss wenn man nicht intern anschließen mag.
 

dr_tommi

alter Oldie
kann man dabei eine Platte an einen normalen SATA Anschluss klemmen und einfach den Platteninhalt sichern, oder muss zwingend wieder über einen RAID Controller der Inhalt ausgelesen werden?
Wenn es RAID 1 war, dann kann man eine der beiden Platten (sprich eine die noch funktioniert) einfach über SATA anschließen und die Daten darauf wegsichern. Ginge auch über einen externen USB zu SATA Anschluss wenn man nicht intern anschließen mag.
Sowas hat bei mir noch nie funktioniert.
Aber ich arbeite auch erst seit 25 Jahren mit Servern und Raids in verschiedenen Konstellationen.
 

SkAvEnGeR

Master of Tools
Auch meine Erfahrung ist, dass man Daten von einer Platte, die in einem RAID1 steckte, nicht einfach so sichern kann.
Die Spiegelung regelt ja der Controller und die Platten sind einzeln nicht direkt ansprechbar.

Ich hatte letztens einen ähnlichen Fall. Auch einfach nach x Jahren RAID1 ausgefallen - da war es der Controller.
Ich musste die Platte einzeln am SATA betreiben und dann mit einem Datenrettungs-Tool die Daten sichern (R-Studio).
Anders wurde die Plattre bzw. deren Partitionierung und Dateisystem von Windows nicht erkannt.
Alternativ kannst du auch erstmal mit dem kostenlosen R-Undelete probieren.
 

Dorwyn

Bekanntes Mitglied
kann man dabei eine Platte an einen normalen SATA Anschluss klemmen und einfach den Platteninhalt sichern, oder muss zwingend wieder über einen RAID Controller der Inhalt ausgelesen werden?
Wenn es RAID 1 war, dann kann man eine der beiden Platten (sprich eine die noch funktioniert) einfach über SATA anschließen und die Daten darauf wegsichern. Ginge auch über einen externen USB zu SATA Anschluss wenn man nicht intern anschließen mag.
Sowas hat bei mir noch nie funktioniert.
Aber ich arbeite auch erst seit 25 Jahren mit Servern und Raids in verschiedenen Konstellationen.
Also ich hatte den Fall bislang genau ein einziges Mal. Zugegeben... schon ein paar Jahre her. Da ist mir der Partner im RAID 1 abgeraucht und ich hab die Platte dann in einem zweiten Rechner eingebaut und konnte normal auf die Daten zugreifen und kopieren. War allerdings auch keine Systempartition sondern nur Daten. Backupfiles um genau zu sein. Das waren einzelne, größere Files mit ein paar Hundert MB bis ca. zwei Gibabyte Größe.
 

eumel_1

rüpelhafter Bierhippie
Angeregt durch die Diskussion hier habe ich eben mal getestet, Hardware Adaptec 6405 mit 2 x 1TB WB Black 2,5" im Raid 1 (Mirror) als Datenlaufwerk D:
jede einzelne der beiden Platten wird am USB-Adapter meines Laptops problemlos erkannt und ist lesbar.
Meines Wissens schreibt der Controller eine Signatur in den Bootsektor um zu erkennen, ob es sich um Device 0 oder Device 1 handelt (oder auch 2 - 5 bei Raid 5).
Anders als Raid 5, vor Jahren haben wir mal analysiert wie da die Daten verteilt werden, es wurden Daten in Blöcken zu jeweils 64k angelegt.
Kann heute bei den Plattengrößen sicherlich auch anders sein, aber im Jahre 2004 im Hardwarelab hatten wir das mal mit dem Hexeditor genau ausgeforscht und die Platten eines Raid 5 ausgelesen.
 
Zuletzt bearbeitet:

blackdeath

GROSS!ARTIG?
Danke für das testen der Möglichkeit, ich gebe das mal weiter und hoffe das kann dann auch umgesetzt werden.

Ich weiss nämlich nicht wie genau mein Freund die Dinge so umsetzt die ich ihm das sage, mal ein Beispiel:

Er hatte keinen Zugriff auf eine HDD und da sagte ich ihm, Stecker an der HDD mal abziehen und wieder stecken, manchmal verrutschen Kabel beim Hantieren im Gehäuse.
Nach Aussage hatte er das dann auch gemacht, dann haben wir rumprobiert wieso der Zugriff nicht klappt und bisschen später sagt er "da liegt ein Datenkabel versteckt unter der HDD".

Also steckte das Kabel nicht an der HDD und das abstecken und neustecken hatte er nicht gemacht.

Deswegen ist dieser Telefonsupport etwas schwierig für mich und ich kann nicht immer alle Fragen hier beantworten.
 

blackdeath

GROSS!ARTIG?
Ich hatte auf beide Stecker hingewiesen, aber nun denn passiert halt bei TelefonSupport ohne persönlich anwesend sein zu können.

Ist einfach so, das beste draus machen.
 

dr_tommi

alter Oldie
Ich hatte auf beide Stecker hingewiesen, aber nun denn passiert halt bei TelefonSupport ohne persönlich anwesend sein zu können.

Ist einfach so, das beste draus machen.
Für sowas gibt es die Videotelefonie, können inzwischen fast alle Smartphones. ;) Egal ob nun Whatsapp oder Facetime.
Nur telefonisch hat man gerade bei älteren Mitmenschen, also noch älter als wir, schon manchmal ein paar Probleme. Schon alleine mit "Hören" und dem "Verstehen". Nicht alles kommt akustisch rüber und und meistens wird auch nur ein Teil davon verstanden.
 
Zuletzt bearbeitet:

blackdeath

GROSS!ARTIG?
Ja die einfachsten Dinge :icon_funny: , Videotelefonie das wäre es gewesen. :yo

Für die nächste Geräteüberprüfung werde ich das aber befolgen!
 

SkAvEnGeR

Master of Tools
Angeregt durch die Diskussion hier habe ich eben mal getestet, Hardware Adaptec 6405 mit 2 x 1TB WB Black 2,5" im Raid 1 (Mirror) als Datenlaufwerk D:
jede einzelne der beiden Platten wird am USB-Adapter meines Laptops problemlos erkannt und ist lesbar.
Schön, dass es bei dir geklappt hat.
ABER: bei mir hat die gleiche Vorgehensweise leider nicht geklappt
meines Wissens ist es ein Unterschied, ob das RAID als reines Datengrab oder als Startlaufwerk für Windows verwendet wird.
Weiterhin kommt es natürlich immer auch auf den verwendeten Controller und dessen Konfig an.
In meinem Fall wurde im BIOS des Controllers ein virtuelles Array angelegt - dadurch hat der Controller die Verwaltung der Platten übernommen und ich konnte von ihnen eben nicht ganz normal starten und war so gezwungen, ein Recovery-Programm zu nutzen.

Leider wissen wir alle nun nicht, wie der Controller auf dem Mainboard von @blackdeath das geregelt hat.
 

blackdeath

GROSS!ARTIG?
Ja, es könnte den Eindruck entstehen, ich habe einen Fehler und kaschiere das über die Aussage "ein Freund hat das Problem" aber das liegt hier nicht vor.
Es ist nicht mein Rechner und ich bekomme die Infos per Telefon.

Also eine Platte aus dem Raid konnte in einem USB Wechselrahmen erkannt werden, da lief ein Versuch einer Datenrettung.
Die 2. Platte aus dem Raid wurde als defekt angezeigt, der Defekt war wohl vorher nicht aufgefallen.

Wobei mir das irgendwie zu viele Fehler auf einmal sind, die System-SSD war zerschossen und ein Teil vom Raid ist auch defekt, hatte ihn schon gefragt ob es Spannungsschwankungen in letzter Zeit bei ihm gab, scheinbar nicht. Vielleicht ist es auch einfach nur das Alter der Bauteile und die machen nun nach und nach schlapp.
 
Oben Unten