Erledigt Win 10 Pro falsche Bitrate im Explorer

vaGem

Bekanntes Mitglied
Hallo,
vor kurzem ist mir aufgefallen das im Explorer einige MP3 Dateien
in der Spalte Bitrate mit 0kBit/s angezeigt werden. Bei den 320kBit/s ist mir das aufgefallen.

Jetzt aber noch etwas komisches:
Bei Tag&Rename werden die Dateien als VBR320-326 angezeigt.
Bei MP3Tag richtig mit 320.
Foobar und Winamp zeigt auch richtig an.

So, bei Foobar gibt es ja die Option "Fix VBR Header" und "Rebuilt MP3 Stream",
hab beides ausprobiert mit dem Resultat das der Explorer jetzt 307kBit/s anzeigt,
bei MP3Tag und Tag&Rename aber nur 64kBit/s. Spiel ich die Datei im Winamp bzw.
Foobar ab, wird mir 320kBit/s angezeigt.

Alle Dateien die betroffen sind wurden vor Monaten noch richtig angezeigt aber auch fast alle Neueren.
Irgendwie bin ich mit mein Latein am Ende, Convertier ich die neu auf 320 werden
die MP3 Dateien wieder richtig angezeigt aber das kann ja nicht die Lösung sein.
Wenn jetzt nur ein paar davon befallen wären, würde ich die neue Convertieren aber
wir Reden hier von ein paar mehr.
Getestet hab ich zum reparieren auch MP3val und MP3Diags mit dem Ergebnis das sich nichts geändert hat.

Vielleicht hilft das Schwarmwissen woran es liegen und ändern kann.



System: Intel Core i7-3770 CPU 3.50Ghz 32GB Ram
BS: Win10pro x64 21H1 Build 19043.1081

[Edit]
Ich hab mal eine Datei hochgeladen zum Testen ob bei euch auch die Probleme bestehen.
1x Original
1x mit Foobar "repariert"

Testfile


Danke für eure Antworten
 
Zuletzt bearbeitet:

GiveThatLink

Bekanntes Mitglied
Vergiss den Explorer und nimm das, was es richtig anzeigt, den Rest in die Tonne.

Der Autor von mp3tag ist für Fehlermeldungen offen, und auch für Donations.
 

vaGem

Bekanntes Mitglied
mp3tag ist für mich eigentlich keine Option, da die Darstellung der einzelnen Ordner
unübersichtlich sind (keine Verzeichnisse und alle Titel untereinander) und kein Export in html gibt (?) so wie bei Tag&Rename.
Benutze mp3tag nur um verschiedene Covers in einem Ordner befindlichen MP3`s
schnell einzubinden.
 

vaGem

Bekanntes Mitglied
Ok, du hast recht.
Mein Problem besteht darin das bei mp3tag nicht "vernünftig" sortiert wird, ich bräuchte es schon so
wie bei Tag&Rename.

tag.jpg


mp3tag.jpg


Wenn ich mir dann überlege was es für ein Chaos bei mp3tag bei einer Discography wäre.
 

vaGem

Bekanntes Mitglied
mp3tag nehme ich nur wenn ich mehrere einzel Songs hab wo ich das passende Cover einfügen will.
Bei Tag&Rename wäre das ein zu großer Aufwand, da müsste ich jeden einzelnen Song anklicken und das
passende Cover dazu reinladen. Bei mp3tag geht das mit den richtigen Parameter in einem Rutsch, vorrausgesetzt
das Cover hat den gleichen Namen wie der Song.
Für alles andere benutze ich Tag&Rename.

Ist aber eigentlich nicht der Sinn dieses Freds, die Frage war ja eigentlich warum die Bitraten falsch angezeigt werden.
 

vaGem

Bekanntes Mitglied
Es hätte schon was gebracht wenn jemand meine Testfiles runtergeladen
und eben eine Info schreibt ob bei demjenigen das auch so ist.
Ich werd ja wohl nicht der einzige hier sein der Win10 und/oder Tag&Rename und/oder mp3tag benutzt.

Da hätte man zumindest schonmal ein Ansatzpunkt woran es liegen kann
 

sPIfF c99

fearless spaceman
Ich denke dass das Problem davon kommt womit das MP3 erstellt wurde. Bei mir liegt das Problem so: Explorer ok, VLC sagt meistens 30 kbit/s. Richtig zeigt es eigentlich nur Foobar an (V0 und die jeweilige Bitrate)
Bei mir betrifft es MP3 die ich mit Foobar erstelle. Basis ein Flac File. Im Foobar wähle ich dann Convert to MP3, in meinem Fall variable MP3 (v0).
 

sPIfF c99

fearless spaceman
Das Testfile hatte ich vorher nicht gesehen. OkBit.mp3 zeigt an 0 kbps, 307_bezw64kBit.mp3 zeigt an 307kbps. Getestet mit englischem Windows 10 20H2
 

GiveThatLink

Bekanntes Mitglied
Das Testfile hatte ich vorher nicht gesehen. OkBit.mp3 zeigt an 0 kbps, 307_bezw64kBit.mp3 zeigt an 307kbps. Getestet mit englischem Windows 10 20H2
Ich auch nicht. mp3tag wie gesagt (beide 320kbit), der hier:
https://www.mp3-tag-editor.de/mp3tageditor/de/download/

zum 0kbit sagt es : 324kbit vbr,
zum 307_64 sagt: 64kbit (wahrscheinlich cbr)

Das hier https://www.xdlab.ru/en/ sagt 0kbit und 64kbit, letzteres ist richtig.

Winamp sagt für beide 320kbit (cbr, vbr wird sonst extra angegeben)

Warum alle Programme so unterschiedlich anzeigen - ich würde behaupten, dass diese Infos im MP3 schlichtweg Murks sind. Wenn man die Spieldauer faken kann, ist auch sowas möglich. Und es gibt auch Programme, die Tags falsch beschreiben.
 

TLNZodiac

Bekanntes Mitglied
Ich habe die Testdaten runtergeladen und jeweils in Kopie durch die Software FileOptimizer gejagt. Die ist eigentlich dazu da, Dateien verschiedener Typen lossless oder lossy zu verkleinern. Dazu werden die Dateien durch verschiene Toolchains gejagt. Hier die jeweiligen Metadaten, so angezeigt in Directory Opus; die "- Copy" ist jeweils die Kopie nach Behandlung:
0kBit.mp3.png
0kBit - Copy.mp3.png
307_bzw_64kBit.mp3.png
307_bzw_64kBit - Copy.mp3.png

Es scheint geholfen zu haben. Vielleicht kann das helfen, die Dateien wieder zu reparieren.
 

vaGem

Bekanntes Mitglied
Super,
damit weiß ich zumindest das es wirklich an den Dateien liegt und nicht eine laune meines Rechners :yo

Danke an allen die hier geholfen haben :icon_prost:

Fileoptimizer schau ich mir mal genauer an, kannte das Programm nocht nicht.
 

sPIfF c99

fearless spaceman
Es ist ein Fehler im MP3 Header. Mit Foobar kann man via utilities\Fix VBR MP3 Header
das File fixen. Windows zeigt beim 0kbit bei mir nun 307 kbps.
 

vaGem

Bekanntes Mitglied
Das hab ich auch gemacht gehabt, siehe Eingangspost, danach hat Tag&Rename und mp3tag
64kbps angezeigt.
 
Oben Unten