SL 10.6.8 - Logitech C910 lässt sich nicht initialisieren/funktioniert nicht

Dieses Thema im Forum "Mac" wurde erstellt von Thunderbird696, 9 November 2012.

  1. Thunderbird696

    Thunderbird696 Aktives Mitglied

    Registriert seit:
    29 Juli 2001
    Beiträge:
    303
    Hallo,

    ich habe mir die Logitech C910 geholt und sie funktioniert an meinem Hackintosh leider nicht.

    Das Proggi Photo Booth erkennt zwar nach der Paketinstallation, dass eine Cam angeschlossen ist, aber die Cam kann nicht initialisiert werden - folglich kein Bild!

    Die Tonausgabe funktioniert aber!

    Schließe ich die Logi an meine Windose an, funktioniert alles einwandfrei. Und aktiviere ich z.B. Skype leuchtet auch der blaue LED-Streifen links und rechts der Optik. Dass passiert nicht, wenn die Cam am Hackintosh hängt, da bleiben die LED dunkel.

    Ich habe ein Gigabyte EP45-UD3LR, 4 GB Ram sowie die Geforce 9800 GT und ansonsten läuft mein Snow Leopard (10.6.8 ) richtig rund.

    Kann das an einer BIOS-Einstellung liegen..???

    Alles anderen USB-Geräte (Scanner, Drucker, ext. HDD, etc) laufen einwandfrei.

    Ich habe von Logi mir auch den aktuellen Treiber für SL runtergeladen und es auch mit einem Treiber von Macam probiert, wobei der Macom-Treiber überhaupt keine Cam erkennt.

    Die Cam wird mit Logi-Treiber im USB-Gerätebaum unter USB-Hochgeschwindigkeits-Bus als "sonstiges Gerät" erkannt mit Produkt-ID 0x0821, Hersteller-ID 0x046d, Version 0.10 gefolgt von Seriennr., Standort-ID und der verfügbaren und der erforderlichen Stromstärke von 500 mA.

    Würde mich riesig freuen, wenn mir hier jemand weiterhelfen kann. Mir ist auch bewusst, dass ich bei der Cam diverse Funktionen unter OSX nicht nutzen......aber wenigstens ein Bild wäre schon schön.

    Ansonsten noch ein sonniges und stressfreies Weekend.

    Gruß
    Thunderbird
  2. Wolf Larsen

    Wolf Larsen Kapitän

    Registriert seit:
    2 Juni 2001
    Beiträge:
    2.560
    AW: SL 10.6.8 - Logitech C910 lässt sich nicht initialisieren/funktioniert nicht

    Mit anderen USB-Cams gab es unter Mac immer schon Probleme. Es gab Software wie iUSBCam für iChat. Es gibt andere Treiber wie MacCam.

    Wolf
  3. Thunderbird696

    Thunderbird696 Aktives Mitglied

    Registriert seit:
    29 Juli 2001
    Beiträge:
    303
    AW: SL 10.6.8 - Logitech C910 lässt sich nicht initialisieren/funktioniert nicht

    Hi Wolf,

    den Macam-Treiber habe ich schon probiert....ohne Erfolg.

    Wie groß ist denn die Wahrscheinlichkeit, dass ich nach einem Update auf Mountain Lion die Cam nutzen könnte??? Die Treiberunterstützung soll angeblich besser sein...

    Gruß
    Thunderbird
  4. equipe

    equipe Zeitreisender

    Registriert seit:
    2 Januar 2002
    Beiträge:
    364
    AW: SL 10.6.8 - Logitech C910 lässt sich nicht initialisieren/funktioniert nicht

    Hallo Thunderbird,

    ich habe genau dasselbe Modell wie Du, eine Logitech C910. Und an meinem Mac funktioniert sie unter Lion absolut perfekt. Ich kann sie sogar mit Photobooth als Ersatz für die interne iSight nutzen. Andere Betriebssysteme habe ich nicht getestet.

    Das bedeutet wahrscheinlich, dass Dein Problem entweder mit Snow Leopard zusammenhängt - oder mit der Tatsache, dass Du die Kamera an einem Hackintosh betreiben willst.

    Falls es Dir hilft, kann ich Dir natürlich das genaue Verhalten der blauen LED-Streifen erklären oder auch mal einen Auszug aus dem Systembericht zitieren, aus dem dann hervorginge, wie die Cam bei mir erkannt wird.

    Viele Grüße
    equipe
  5. Joerd

    Joerd Aktives Mitglied

    Registriert seit:
    21 Juni 2001
    Beiträge:
    4.390
    AW: SL 10.6.8 - Logitech C910 lässt sich nicht initialisieren/funktioniert nicht

    Am Hackintosh wird das Problem recht sicher nicht liegen, sondern an der Betriebssystemversion.

    Da auch 10.8. problemlos auf einem Hackintosh verwendbar ist, rate ich zu einem Update, wenigstens auf 10.7 (ab da darf man auch unter OS X die Fenstergröße mit der Maus nicht nur in der unteren rechten Ecke verändern, ein 25jähriger Zopf, den Apple endlich abgeschnitten hat und der Nutzer anderer Betriebssysteme schon immer genervt hat).
  6. xtraa_

    xtraa_ Serviervorschlag

    Registriert seit:
    28 Februar 2003
    Beiträge:
    14.988
    AW: SL 10.6.8 - Logitech C910 lässt sich nicht initialisieren/funktioniert nicht

    Ich hab mir mal Dein Paket mit Pacifist angeschaut und ich sehe da zwar jede
    Menge Frameworks aber keine Kernel-Extension. 0x0821046d müsstest Du
    jedenfalls in eine .kext einsetzen.

    Allerdings sieht das ganze Paket ziemlich eklig aus. Die haben da unglaublich
    viele dylibs drin, vermutlich waren das umgeschulte Windows Programmierer
    mit .dll Erfahrung :D Jedenfalls installieren sich da Tonnen von Logitech-Müll
    anstatt dass die einfach direkt auf die bereits vorhandene Infrastruktur des
    Systems zurückgreifen. - hab ich den Eindruck, aber vielleicht ist der ja falsch.

    Du kannst ja mal schauen, was da so geladen wird: Im Terminal mal kextstat
    eingeben und die Liste ansehen oder hier copypasten.

    Mögliche Fehlerquellen sind: Keine Kext geladen, oder USB evtl. nicht zwei
    punkt null?

    USB 2.0 muss im Gerätebaum unter USB-Hochgeschwindigkeits-Bus
    angezeigt werden. USB 3.0 unter USB Super-Speed-Bus.

    Ist das nicht der Fall, dann werden Deine USB 2.0 Anschlüsse im Rechner als
    USB 1.0 erkannt und Du musst mal sehen, welche UHCI oder EHCI kexte es
    gibt, bzw. eine passende Kernelflag wie USBBusFix=Yes beim starten
    eingeben.


    Gruß
    xtraa
  7. Thunderbird696

    Thunderbird696 Aktives Mitglied

    Registriert seit:
    29 Juli 2001
    Beiträge:
    303
    AW: SL 10.6.8 - Logitech C910 lässt sich nicht initialisieren/funktioniert nicht

    @all
    ...bin gerade zum "DAU" geworden und muss es jetzt erstmal schaffen, auf die Wiederherstellungsebene vom SL zu kommen....ganz offensichtlich habe ich nichts anständiges mehr zum booten ..*grrr*

    ...aber die Hinweise hier lesen sich vielversprechend ;)!

    Gruß
    Thunderbird
  8. xtraa_

    xtraa_ Serviervorschlag

    Registriert seit:
    28 Februar 2003
    Beiträge:
    14.988
    AW: SL 10.6.8 - Logitech C910 lässt sich nicht initialisieren/funktioniert nicht

    Auch nicht mit -x in den abgesicherten?
  9. Thunderbird696

    Thunderbird696 Aktives Mitglied

    Registriert seit:
    29 Juli 2001
    Beiträge:
    303
    AW: SL 10.6.8 - Logitech C910 lässt sich nicht initialisieren/funktioniert nicht

    @xtraa
    ...auch nicht mit -x....da laufen die Seiten mit den gelesenen Files nur so durch und als letztes erscheint dann eine elendig lange Liste mit Files, die nicht gefunden wurde....und das war es dann.... :(
  10. Thunderbird696

    Thunderbird696 Aktives Mitglied

    Registriert seit:
    29 Juli 2001
    Beiträge:
    303
    AW: SL 10.6.8 - Logitech C910 lässt sich nicht initialisieren/funktioniert nicht

    @xtraa
    Mein SnowLeopard läuft wieder rund ;)!
    Jetzt kann ich mich wieder mit dem Problem der Logitech-Cam befassen.
    Im Verzeichnis S/L/E gibt es übrigens nur eine kext von Logitech und die hat den Namen LogitechForceFeedback.kext (ist eigentlich ein Joystick von Logi!?!?!)

    Hier das Ergebnis von kextstat auf meinem Hacky:
    (ich hoffe, dass du jetzt keinen Herzkasper bekommst bei dieser Aufstellung)

    Index Refs Address Size Wired Name (Version) <Linked Against>
    1 60 0 0 0 com.apple.kpi.bsd (10.8.0)
    2 4 0 0 0 com.apple.kpi.dsep (10.8.0)
    3 81 0 0 0 com.apple.kpi.iokit (10.8.0)
    4 87 0 0 0 com.apple.kpi.libkern (10.8.0)
    5 69 0 0 0 com.apple.kpi.mach (10.8.0)
    6 26 0 0 0 com.apple.kpi.private (10.8.0)
    7 43 0 0 0 com.apple.kpi.unsupported (10.8.0)
    8 0 0 0 0 com.apple.kernel.6.0 (7.9.9)
    9 0 0 0 0 com.apple.kernel.bsd (7.9.9)
    10 3 0 0 0 com.apple.kernel.iokit (7.9.9)
    11 3 0 0 0 com.apple.kernel.libkern (7.9.9)
    12 3 0 0 0 com.apple.kernel.mach (7.9.9)
    13 9 0x5541c000 0x4000 0x3000 com.apple.iokit.IOACPIFamily (1.3.0) <7 6 4 3>
    14 21 0x55630000 0x1d000 0x1c000 com.apple.iokit.IOPCIFamily (2.6.5) <7 6 5 4 3>
    15 1 0x5566c000 0x42000 0x41000 com.apple.driver.AppleACPIPlatform (1.5) <14 13 7 6 5 4 3 1>
    16 0 0x4f1ed000 0x2000 0x1000 es.osx86.driver.EvOreboot (1.0.3) <4 3>
    17 0 0x4f20d000 0x2000 0x1000 org.tgwbd.driver.NullCPUPowerManagement (1.0.0d2) <7 4 3>
    18 0 0x5572c000 0x24000 0x23000 com.apple.driver.AppleIntelCPUPowerManagement (142.6.0) <7 6 5 4 3 1>
    19 8 0x5570f000 0x19000 0x18000 com.apple.iokit.IOStorageFamily (1.6.3) <7 6 5 4 3 1>
    20 0 0x557a1000 0x11000 0x10000 com.apple.driver.DiskImages (289.1) <19 7 6 5 4 3 1>
    21 2 0x555f8000 0x7000 0x6000 org.netkas.FakeSMC (4.0.0) <13 7 5 4 3>
    22 0 0x55482000 0x4000 0x3000 org.mozodojo.IntelCPUMonitor (1.0.1) <21 7 5 4 3>
    24 0 0x5577d000 0x8000 0x7000 com.apple.nke.applicationfirewall (2.1.14) <7 6 5 4 3 1>
    25 2 0x55750000 0x3000 0x2000 com.apple.kext.AppleMatch (1.0.0d1) <4 1>
    26 0 0x5583a000 0x5000 0x4000 com.apple.security.quarantine (0) <25 7 6 5 4 2 1>
    27 0 0x5584a000 0x8000 0x7000 com.apple.security.sandbox (1) <25 7 6 5 4 2 1>
    28 0 0x55834000 0x3000 0x2000 com.apple.security.TMSafetyNet (6) <7 6 5 4 2 1>
    29 0 0x55837000 0x3000 0x2000 com.apple.driver.AppleAPIC (1.4) <4 3>
    30 0 0x55845000 0x4000 0x3000 com.apple.driver.AppleSMBIOS (1.7) <7 4 3>
    31 0 0x55852000 0x3000 0x2000 com.apple.driver.AppleHPET (1.5) <13 7 5 4 3>
    32 0 0x55979000 0x5000 0x4000 com.apple.driver.AppleRTC (9.9) <13 5 4 3 1>
    34 4 0x5c558000 0x3c000 0x3b000 com.apple.iokit.IOHIDFamily (1.6.6) <7 6 5 4 3 1>
    35 0 0x556fd000 0x4000 0x3000 com.apple.driver.AppleACPIButtons (1.5) <34 15 13 7 6 5 4 3 1>
    36 1 0x55709000 0x3000 0x2000 com.apple.driver.AppleEFIRuntime (1.4.0) <7 6 5 4 3>
    37 7 0x5c5c8000 0x2f000 0x2e000 com.apple.iokit.IOUSBFamily (9.9.9) <14 7 5 4 3 1>
    38 0 0x5599e000 0x10000 0xf000 com.apple.driver.AppleUSBUHCI (9.9.9) <37 14 7 5 4 3 1>
    40 0 0x5597e000 0x14000 0x13000 com.apple.driver.AppleUSBEHCI (9.9.9) <37 14 7 5 4 3 1>
    41 1 0x55705000 0x4000 0x3000 com.apple.kext.OSvKernDSPLib (1.3) <5 4>
    42 3 0x559e4000 0x18000 0x17000 com.apple.iokit.IOAudioFamily (1.8.3fc2) <41 5 4 3 1>
    43 0 0x559ae000 0x22000 0x21000 org.voodoo.driver.VoodooHDA (0.2.1) <42 14 7 5 4 3 1>
    44 3 0x55992000 0x6000 0x5000 com.apple.iokit.IOAHCIFamily (2.0.6) <5 4 3 1>
    45 0 0x559d0000 0x14000 0x13000 com.apple.driver.AppleAHCIPort (2.1.7) <44 14 5 4 3 1>
    46 0 0x5c67d000 0x6000 0x5000 com.apple.driver.AppleEFINVRAM (1.4.0) <36 7 5 4 3>
    47 0 0x5c683000 0x11000 0x10000 org.usrsse2.NVClockX (1.0.2d1) <21 14 7 5 4 3>
    48 1 0x5d745000 0xd000 0xc000 com.apple.iokit.IOATAFamily (2.5.1) <5 4 3 1>
    49 0 0x5c6e7000 0x6000 0x5000 com.jmicron.JMicronATA (1.0.2) <48 14 4 3>
    50 2 0x5d7fa000 0x43000 0x42000 com.apple.iokit.IOFireWireFamily (4.2.6) <5 4 3 1>
    51 0 0x5d7b0000 0x27000 0x26000 com.apple.driver.AppleFWOHCI (4.7.3) <50 14 7 6 5 4 3 1>
    52 3 0x5d785000 0x1a000 0x19000 com.apple.iokit.IOSCSIArchitectureModelFamily (2.6.8) <5 4 3 1>
    53 0 0x5d79f000 0x9000 0x8000 com.apple.iokit.IOAHCISerialATAPI (1.2.6) <52 44 5 4 3 1>
    54 0 0x5590d000 0x2000 0x1000 com.apple.iokit.IOUSBUserClient (4.2.4) <37 7 5 4 3 1>
    55 0 0x5d964000 0xf000 0xe000 com.apple.driver.AppleUSBHub (9.9.9) <37 5 4 3 1>
    57 0 0x5da85000 0x6000 0x5000 com.apple.AppleFSCompression.AppleFSCompressionTypeZlib (1.0.0d1) <6 4 3 2 1>
    58 0 0x5da9e000 0x5000 0x4000 com.apple.BootCache (31.1) <7 6 5 4 3 1>
    59 0 0x5dac6000 0x2d000 0x2c000 at.obdev.nke.LittleSnitch (2.3.09) <7 5 4 3 1>
    60 0 0x5db15000 0x7000 0x6000 com.apple.iokit.SCSITaskUserClient (2.6.8) <52 19 5 4 3 1>
    61 3 0x5db05000 0x8000 0x7000 com.apple.iokit.IOCDStorageFamily (1.6.1) <19 5 4 3 1>
    62 2 0x5db0d000 0x6000 0x5000 com.apple.iokit.IODVDStorageFamily (1.6) <61 19 5 4 3 1>
    63 1 0x5db54000 0x5000 0x4000 com.apple.iokit.IOBDStorageFamily (1.6) <62 61 19 5 4 3 1>
    64 0 0x5db99000 0x17000 0x16000 com.apple.iokit.IOSCSIMultimediaCommandsDevice (2.6.8) <63 62 61 52 19 5 4 3 1>
    65 0 0x5d979000 0x4000 0x3000 com.apple.driver.AppleUSBComposite (3.9.0) <37 4 3 1>
    66 0 0x5db6f000 0x7000 0x6000 com.apple.iokit.IOUSBHIDDriver (4.2.0) <37 34 5 4 3 1>
    67 0 0x5db7d000 0x14000 0x13000 com.apple.iokit.IOAHCIBlockStorage (1.6.4) <44 19 5 4 3 1>
    68 0 0x5dc02000 0x3000 0x2000 com.apple.driver.XsanFilter (402.1) <19 5 4 3 1>
    69 2 0x5ddeb000 0x17000 0x16000 com.apple.iokit.IONetworkingFamily (1.10) <7 6 5 4 3 1>
    70 0 0x5de1f000 0x21000 0x20000 com.lnx2mac.driver.RealtekRTL81xx (0.0.67) <69 14 5 4 3 1>
    71 0 0x5dd3d000 0x2000 0x1000 com.apple.driver.AppleSMBusPCI (1.0.10d0) <14 5 4 3>
    73 5 0x5dee8000 0x22000 0x21000 com.apple.iokit.IOGraphicsFamily (2.2.1) <14 7 5 4 3>
    75 2 0x5dd7d000 0x9000 0x8000 com.apple.iokit.IOSerialFamily (10.0.3) <7 6 5 4 3 1>
    76 1 0x5dda3000 0x9000 0x8000 com.apple.driver.Apple16X50Serial (3.0) <75 14 5 4 3>
    77 0 0x5dd45000 0x2000 0x1000 com.apple.driver.Apple16X50ACPI (3.0) <76 13 4 3>
    78 7 0x5df90000 0x2c000 0x2b000 com.apple.iokit.AppleProfileFamily (41) <14 7 6 5 4 3 1>
    80 1 0x5de64000 0xa000 0x9000 com.apple.driver.AppleSMC (3.1.0d5) <13 7 5 4 3>
    82 0 0x5de58000 0x9000 0x8000 com.apple.iokit.IOFireWireIP (2.0.3) <69 50 5 4 3 1>
    83 2 0x5de40000 0xd000 0xc000 com.apple.iokit.IONDRVSupport (2.2.1) <73 14 7 5 4 3>
    84 2 0x5edc1000 0x2f1000 0x2f0000 com.apple.NVDAResman (6.3.7) <83 73 14 5 4 3 1>
    87 1 0x55610000 0x3000 0x2000 com.apple.iokit.IOSMBusFamily (1.1) <5 4 3>
    88 0 0x55619000 0x9000 0x8000 com.apple.driver.AppleSMBusController (1.0.10d0) <87 14 13 5 4 3>
    89 0 0x5dece000 0x4000 0x3000 com.apple.driver.AudioIPCDriver (1.1.6) <42 5 4 3 1>
    92 0 0x5dea2000 0x6000 0x5000 com.apple.Dont_Steal_Mac_OS_X (7.0.0) <80 7 4 3 1>
    93 0 0x5de8b000 0x7000 0x6000 com.apple.driver.AppleIntelPenrynProfile (17) <78 6 4 3>
    94 0 0x5fc9a000 0x415000 0x414000 com.apple.nvidia.nv50hal (6.3.7) <84 14 4 3>
    95 0 0x5de97000 0x9000 0x8000 com.apple.iokit.IOBluetoothSerialManager (2.4.5f3) <75 7 5 4 3 1>
    97 0 0x5e25c000 0xc9000 0xc8000 com.apple.GeForce (6.3.7) <84 83 73 14 7 6 5 4 3 1>
    98 0 0x5db1c000 0xb000 0xa000 com.apple.iokit.IOSurface (74.2) <7 5 4 3 1>
    99 0 0x5deb9000 0x7000 0x6000 com.apple.driver.AppleMCCSControl (1.0.20) <73 14 7 5 4 3 1>
    100 2 0x5dedd000 0x6000 0x5000 org.voodoo.driver.PS2Controller (1.1.0) <12 11 10>
    101 0 0x5dc4f000 0x5000 0x4000 com.apple.driver.AppleUpstreamUserClient (3.5.7) <73 14 13 7 5 4 3 1>
    102 0 0x5dc3f000 0x3000 0x2000 com.apple.driver.AppleProfileCallstackAction (20) <78 5 4 3 1>
    103 0 0x5dc1a000 0x3000 0x2000 org.voodoo.driver.PS2Keyboard (1.1.0) <100 34 12 11 10 7 6 5 4 3 1>
    104 0 0x5dc0d000 0x8000 0x7000 org.voodoo.driver.PS2Trackpad (1.1.0) <100 34 12 11 10 7 6 5 4 3 1>
    105 0 0x5dc1d000 0x3000 0x2000 com.apple.driver.AppleProfileKEventAction (10) <78 4 3 1>
    107 0 0x5dc25000 0x3000 0x2000 com.apple.driver.AppleProfileRegisterStateAction (10) <78 4 3 1>
    108 0 0x5dc32000 0x3000 0x2000 com.apple.driver.AppleProfileThreadInfoAction (14) <78 6 4 3 1>
    109 0 0x5dc3b000 0x3000 0x2000 com.apple.driver.AppleProfileTimestampAction (10) <78 5 4 3 1>
    110 0 0x5dc87000 0x3000 0x2000 com.apple.driver.AppleProfileReadCounterAction (17) <78 6 4 3>
    111 0 0x552b1000 0xa000 0x9000 com.apple.filesystems.autofs (2.1.0) <7 6 5 4 3 1>
    113 0 0x55284000 0x2000 0x1000 com.nvidia.CUDA (1.1.0) <4 1>
    114 0 0x552bb000 0x5000 0x4000 com.apple.driver.AppleHWSensor (1.9.3d0) <5 4 3>
    115 0 0x5ea0f000 0x30000 0x2f000 com.apple.driver.AppleUSBAudio (2.7.6f6) <42 37 5 4 3>
  11. xtraa_

    xtraa_ Serviervorschlag

    Registriert seit:
    28 Februar 2003
    Beiträge:
    14.988
    AW: SL 10.6.8 - Logitech C910 lässt sich nicht initialisieren/funktioniert nicht

    Hm, spontan würd ich sagen, nimm mal die Voodoo PS2 kexts raus:

    104 0 0x5dc0d000 0x8000 0x7000 org.voodoo.driver.PS2Trackpad (1.1.0) <100 34 12 11 10 7 6 5 4 3 1>

    Du hast ja vermutlich eh kein Trackpad am Desktop, das ist eh nur für Lappies gedacht.

    Ebenso brauchst Du die kext nummer 103 auch nicht - ein PS2 Keyboard als unterstützung ist auch nur für
    manche Notebooks gedacht, die laufen intern nämlich tatsächlich noch über ps2.

    103 0 0x5dc1a000 0x3000 0x2000 org.voodoo.driver.PS2Keyboard (1.1.0) <100 34 12 11 10 7 6 5 4 3 1>

    Jedenfalls machen die Voodoo Treiber ziemlich viel murks, ich könnt mir vorstellen,
    dass es auch daran liegen könnte, da ja nach einem kurzen Googeln die Kombi
    Mainboard und Logitech bei anderen Usern problemlos zu laufen scheint.

    Gruß
    xtraa