Erledigt Script beim Abmelden ausführen

Dieses Thema im Forum "Tech & FAQ Forum" wurde erstellt von the gun, 28 Oktober 2018.

  1. the gun

    the gun Der Mensch soll lernen, die Ochsen büffeln.

    Registriert seit:
    12 Dezember 2001
    Beiträge:
    623
    Moin,
    es geht um eine W208 R2 Domain. Dort suche ich nach einer Möglichkeit beim Abmelden für einen bestimmten Benutzer ein Script auszuführen.
    Was ganz einfach ist, ist die Möglichkeit pro Benutzer ein Programm beim Anmelden auszuführen.
    Was auch recht einfach geht, ist per Grouppolicy so etwas für alle Benutzer zu tun.
    Was ich nicht gefunden habe ist die Möglichkeit das für einen bestimmten Benutzer zu tun.
    Fehlen Informationen, hat jemand einen Hinweis?
  2. barabas

    barabas Aktives Mitglied

    Registriert seit:
    22 April 2001
    Beiträge:
    554
    Hallo,

    Grouppolicies lassen sich doch auf einen einzelnen Benutzer "begrenzen" - wo ist das Problem?

    CU
    Barabas
    the gun sagt Danke.
  3. Bestatter

    Bestatter Schwarzfahrer

    Registriert seit:
    30 Mai 2001
    Beiträge:
    4.894
    Ich nutze im Logon-Skipt:
    Code:
    if %username% equ bestatter goto :wasauchimmer
    Das ist sicher auch im Logoff-Skript machbar.
    the gun sagt Danke.
  4. EchtAtze

    EchtAtze Bekannter Mitglied

    Registriert seit:
    9 Juni 2001
    Beiträge:
    5.012
    Kommt darauf an, in welchem Kontext das Script läuft. Wenn es nicht im User-Kontext läuft, dann könnte die Variable fehlen...
    the gun sagt Danke.
  5. the gun

    the gun Der Mensch soll lernen, die Ochsen büffeln.

    Registriert seit:
    12 Dezember 2001
    Beiträge:
    623
    Das wäre natürlich eine Lösung. Das Problem ist, das ich nicht weiß wie ich das tun kann. Evtl. bin ich nur zu blind.
  6. the gun

    the gun Der Mensch soll lernen, die Ochsen büffeln.

    Registriert seit:
    12 Dezember 2001
    Beiträge:
    623
    Das kann ich mal probieren - dann weiß ich es.
  7. the gun

    the gun Der Mensch soll lernen, die Ochsen büffeln.

    Registriert seit:
    12 Dezember 2001
    Beiträge:
    623
    Die Abfrage über den %username% funktioniert zum Glück.
    Damit kann ich mein Problem lösen.
    Danke an alle für die Tips!
    Bestatter sagt Danke.