Erledigt Probleme mit Syncovery

Hellfire

Themenstarter
Team (Mod)
Mitarbeiter
Hallo,

mir ist gerade zufällig aufgefallen, dass Syncovery bei einem manuell angestoßenen Synchronisierungsjob einzelne Dateien nicht kopierte. Dabei soll der Festplatteninhalt komplett auf eine externe Festplatte kopiert werden, was ich in unregelmäßigen Zeitabständen mache. Ich konnte das Problem reproduzieren, auch als ich das zweite Mal den Job anstieß, wurden die Dateien nicht kopiert. Getestet habe ich mit zwei unterschiedlichen externen Festplatten.

Der Auftrag lautet einfach linker Pfad komplett nach rechts kopieren, d.h. die gesamte Festplatte scannen und keinen Ordner ausschließen und dann alle neu hinzugekommenen Dateien links zum rechten Pfad kopieren und ggfs. Dateien verschieben. Stichprobenartig habe ich einmal andere Ordner kontrolliert, dort scheint überall alles ordnungsgemäß kopiert worden zu sein. Das betrifft sowohl neuere Dateien als auch Dateien mit längeren Pfaden. In dem Ordner, in dem die fraglichen Dateien liegen, befinden sich andere Dateien, die vorher erfolgreich erfasst und kopiert wurden. Zudem betrifft es Dateien, die mit einem anderen, automatisierten Job bereits einmal erfolgreich kopiert worden sind.

Hat jemand eine Idee, was ich noch übersehen haben könnte und weshalb diese Dateien nicht kopiert werden? Ich habe sie händisch kopieren können, das war überhaupt kein Problem. Meine Sorge ist nun, dass es vielleicht noch mehr Dateien betrifft, denn das hier ist mir nur zufällig aufgefallen.
 

Hellfire

Themenstarter
Team (Mod)
Mitarbeiter
Hallo,

in den Protokollen ist nichts zu finden, auch werden keine Dateien protokolliert ausgeschlossen.

Die fraglichen Dateien lassen sich normal öffnen und haben keine extravaganten Sonderzeichen im Dateinamen.

Ich habe txt-Testdateien ohne Inhalt in den Quellordner gelegt, eine mit mehr Zeichen im Dateinamen, eine mit weniger. Außerdem zwei Testdateien in einen anderen Ordner. Diese Dateien werden gefunden und kopiert, die fraglichen pdf-Dateien weiterhin nicht.

Nächster Test: Es sind vier pdf-Dateien betroffen, ich habe bei zwei Dateien den Dateinamen geringfügig verändert, diese beiden Dateien wurden danach gefunden, die beiden anderen nicht.

Daraufhin habe ich bei der dritten lediglich einen Unterstrich gelöscht und sie wird erkannt. Die vierte weiterhin nicht. :icon_knock:
 

Rubb

Rover
.... Falls Windows, es gab wohl bei den letzten Updates Einige Fehler, die die Kopierfunktionen beeinflussen ..... für weitere Details evtl. noch einmal im Internet suchen ...
 

Hellfire

Themenstarter
Team (Mod)
Mitarbeiter
Hallo,

Windows 10. Ich habe mir die Protokolle von Syncovery nochmal angesehen, es scheint sonst alles unauffällig zu sein und normal abzulaufen.
 

Hellfire

Themenstarter
Team (Mod)
Mitarbeiter
Hallo,

ich habe weiter getestet, es ist nur noch eine Datei betroffen, die nicht gefunden wird, die anderen drei werden im selben Ordner problemlos erkannt und kopiert:

- Ich kopiere die fragliche Datei in einen anderen Ordner --> hier wird sie gefunden und kopiert

- ich kopiere die fragliche Datei aus dem anderen Ordner zurück dorthin, wo sie eigentlich hingehört und ersetze die vorhandene Datei --> Datei wird nicht gefunden

- ich kopiere die fragliche Datei in einen anderen Ordner und lösche sie im Ordner, wo sie eigentlich hingehört ---> Datei wird in dem anderen Ordner gefunden und kopiert

- ich kopiere die Datei wieder zurück in den Ordner, wo sie hingehört --> Datei wird nicht gefunden.
 

Hellfire

Themenstarter
Team (Mod)
Mitarbeiter
Hallo,

mit einem anderen, automatisiert ablaufenden Profil, das zu einer bestimmten Zeit ausgeführt wird und die fraglichen Dateien bislang noch nicht erfasst hatte, wurden diese ohne jegliche Probleme kopiert, auch die eine Datei, die in dem anderen Profil Schwierigkeiten bereitet.

Ich habe dieses Profil in Syncovery nun gelöscht und ein neues mit identischen Einstellungen erstellt. Es wurden daraufhin insgesamt 376 Dateien gefunden, die das alte Profil nicht kopiert, noch nicht einmal erfasst hatte. Insgesamt waren dies 3,9 GB, unter anderem auch die vier Dateien, bei denen es mir aufgefallen ist. Es ist kein erkennbares Muster zu sehen, es betrifft ganz unterschiedliche Dateitypen in ganz verschiedenen Ordnern.

Das Profil war schon einige Jahre alt und ich habe es auch zwischenzeitlich geringfügig bearbeitet. Ich vermute, dass es damit zu tun hat, denn erstellt habe ich es mit einer anderen Programmversion als ich es später bearbeitet habe.
 
Zuletzt bearbeitet:

Cosmo

Team (Founder)
Mitarbeiter
Das Problem, dass alte Profile von Vorgängerversionen auf neueren Versionen nicht richtig laufen, kenne ich auch bei Syncovery. Bei mir war es ein Profil, welches einen FTP- Upload machen sollte. Das Problem war, dass sich dieses Profil gar nicht in Bewegung setzte.
 
Oben Unten