Problem mit BIOS-Update

Richard Wagner

Themenstarter
Bekanntes Mitglied
Hier gibt es das UEFI-BIOS für mein Asrock X-570 Mainboard:

Ich habe das nicht genau verfolgt, aber da gibt es wohl Sicherheitslücken, die ein Update sinnvoll erscheinen lassen.
Mein Prozessor ist ein AMD Ryzen 7 3700X

Ich hatte noch Version 1.80 (mit Support Microsoft Windows 11). Damit lief alles glatt und stabil.

Beim Update auf Version 2.00 hatte ich große Probleme und dachte, ich hätte mit Bitlocker etwas falsch gemacht. Nur mit Mühe habe ich Windows wieder ans Laufen gekriegt - auf Version 1.80.

Jetzt habe ich es mit BIOS Version 2.20 erneut versucht, und diesmal habe ich ausgiebig getestet. Ergebnis:
Nach dem BIOS-Update ist es nicht möglich, Windows zu starten, egab ob Windows 10 oder 11, auch mit angehaltenem Bitlocker oder nachdem ich ein Image unverschlüsselt wieder hergestellt hatte..
Mit BIOS 2.20 kann ich Windows 10 neu installieren, aber WIndows 11 nicht. Es stürtz immer bei der Einrichtung der Geräte (nach dem ersten Neustart) ab.
Es ist auch kein Implace-Upgrade von Windows 10 auf 11 möglich.

Zurück auf Bios Verson 1.80 funktioniert das alles reibungslos.

Die Probleme sind die gleichen, auch wenn ich die SSD komplett lösche und es Windows selbst überlasse, wie die SSD eingerichtet wird.


Meine Vermutung ist, daß es irgendwelche Inkompatibilitäten in der Hardware gibt und ich damit leben muß, daß ich mein BIOS nicht weiter aktualisieren kann, wenn ich nicht mit großem Aufwand und viel Geld die eizelnen Komponenten durchtesten will.

Oder hat dazu jemand noch eine andere Idee?
 

DrSnuggles

Bekanntes Mitglied
Prüf Mal ob sich RAM Timings oder overclocking verändert nach dem Update.
Ich würde einfach Mal sehr konservative werte einstellen
 

eumel_1

rüpelhafter Bierhippie
Nach einem Bios Update setzt man normalerweise die BIOS-Einstellungen auf Default-Werte zurück - nur um sicherzugehen, dass irgendwelche Speicherzellen nicht mit alten, falschen Werten besetzt sind (weil sich der Ort innerhalb des Speichers verändert hat)!
Erst danach kann man seine persönlichen Einstellungen (abschalten nicht benutzter Hardware oder USB-Anschlüsse, spezielles Timing usw.) wieder herstellen.
Diese Vorgehensweise gilt für alle CPU-typen und alle Mainboardtypen!
 

Richard Wagner

Themenstarter
Bekanntes Mitglied
@eumel_1
Darauf hast Du mich schon einmal hingewiesen. Damals hatte ich es noch nicht beherzigt, aber es hat auch nicht geholfen, weil sich ein Fehler/Defekt im Mainboard zeigte, der nach dem Hardwaretausch behoben war. Diesmal habe ich von Anfang an an Deine Worte gedacht und sie beherzigt. Trotzdem...

Um eine "neue" BIOS-Datei einzuspielen, kann ich im BIOS-Setup die gewünschte BIOS-Datei vom Stick ausgewählen und installieren lassen (Instant Flash). Das habe ich mehrfach gemacht, hin und her. Für den Weg von Version 2.20 zurück auf 1.80 kam ich dann aber auf die Idee, lieber das "ASRock BIOS Flashback feature" zu nutzen.
ASRock BIOS Flashback feature allows you to update BIOS without powering on the system, even without CPU
Ich dachte, das könnte sicherer sein, weil es gründlicher aufräumt als das normale Instant Flash. Ob das stimmt, weiß ich zwar nicht, aber F9 zum Laden der Default-Werte habe ich trotzdem gedrückt. Und dann habe ich schließlich auch für das Update von 1.80 auf 2.20 das "ASRock BIOS Flashback feature" verwendet. Zuletzt habe ich zusätzlich zum BIOS-Tausch vorher und nachher den Strom am Netzteil abgestellt und auf dem Mainboard die drei Knöpfe "Power Button" "Reset Button" und "Clear CMOS Button" gedrückt. Also mehr geht wohl nicht...

@DrSnuggles
Meinst Du das im Overclockingbereich?

01.png


Da habe ich nie etwas gemacht, und in den Screenshots kann ich keinen Unterschied erkennen. Weil ich da nie etwas gemacht habe und mir das mit den tausend Unterseiten, wo ich überall noch etwas einstellen könnte, zu viel war für einen Vergleich mit Screenshots, habe ich ganz verwegen etwas anderes getestet:

Das Mainboard bietet die Option, die Overclocking-Einstellungen auf einen USB-Stick zu speichern. Das habe ich mit BIOS-Version 1.80 gemacht. Nach dem Update auf 2.20 habe ich dann diese alten Einstellungen wieder importiert. Leider war auch das ohne durchschlagenden Erfolg.

Bei meinen weiteren Versuchen verdichtete sich bei mir aber immer weiter der Verdacht, daß es mit dem Adapter für Bluetoth und Wi-Fi zu tun hat, der nach dem BIOS-Update querschießt. Ich brauche BT und W-Lan nicht. Deswegen war es bisher immer deaktiviert.

Was zuerst auffällt, ist die geänderte Bezeichnung nach dem BIOS-Update:
02.png


03.png


Hauptsächlich habe ich versucht, Windows 11 neu zu installieren. Das war eh nur ein Testsystem, mit dem ich nicht viel gemacht habe.

Mit BIOS 1.80 spielt es keine Rolle, ob Bluetooth und W-LAN im BIOS aktiviert oder deaktiviert sind. Setup läuft einfach durch. Mit BIOS 2.20 muß es aktiviert sein. Ist es deaktiviert, stürzt Setup beim Einrichten der Geräte ab!

Wenn ich Windows mit BIOS 1.80 installiert habe, kann ich anschließend BIOS 2.20 einspielen. Windows startet dann auch, wenn auch nur mit aktivierten Killer Wi-Fi. Damit stürzt aber Strelec-DVD beim laden der Netzwerkadapter ab, also noch im Startvorgang!

Die nächste Überraschung mit BIOS 2.20 ist die: Es ist weder in Windows 10 noch 11 möglich, das kabelgebundene Netzwerk zu deaktivieren. Wenn ich das in der Systemsteuerung bei den Adaptereinstellungen versuche, stürzt Windows zuverlässig ab. Wenn der Adapter deaktiviert war, stürzt Windows beim Versuch, ihn zu aktivieren ab.

Jetzt läuft also alles wieder einwandfrei - mit dem alten BIOS! Was mich wundert: Der Killer Wi-Fi-Adapter ist ja fest auf dem Board, und es ist jetzt schon das zweite BIOS-Update in Folge, mit dem ich Probleme habe...
 

eumel_1

rüpelhafter Bierhippie
Scheinbar sind die selber nicht von ihrem Update überzeugt?
Quelle:
Code:
3. If the system is working properly, we recommend keeping the current BIOS / firmware.

Wenn man sich ansieht, was gefixt wurde, stellt sich die Frage:
Hast du eine GeForce RTX 40 Series im System?
Code:
BIOS v.2.20   Improve GPU compatibility for GeForce RTX 40 series.
und für das BIOS in Version 2.00 kommt folgende Frage:
Code:
BIOS v. 2.00   Update AMD AM4 AGESA Combo V2 PI 1.2.0.6b

Also bleibt die erste Aussage (sinngemäß):
Never touch a running system!

Also meine Empfehlung: lass BIOS v.1.80 drauf, wenn alles läuft! (Auch wenn im Allgemeinen gilt: The latest is the greatest!)

Der Grundgedanke, wegen Sicherheitslücken das BIOS zu aktualisieren gilt überwiegend für INTEL-CPUs, da deren MME total im kompromottiert ist.
Klar könnte man das sicher machen, aber dann sinkt die CPU-Performance drastisch. Also versucht man mit kleinen Schritten, ohne die Performance zu killen, eine Lösung zu finden, was aber nicht funktioniert. Deshalb müssen Intel-CPU-Benutzer alle Nase lang das BIOS und die Firmware (für die MME) aktualisieren.
Aus genau diesen Grund sind meine Rechner, die ich vermittele, seit 2 Jahren mit AMD-CPU ausgerüstet.

Aber es gibt bereits Insider die CPUs hacken, die sagen, dass auch bei AMD einiges im Argen sei.
 
Zuletzt bearbeitet:
Oben Unten