Software Frage Pi-Hole - Erfahrungen und Installation

sPIfF c99

fearless spaceman
Falls das so nicht klappt, PI-Hole gem. Anleitung frisch einrichten.
Dann auf dem bisherigen PI-Hole ein Backup machen: Settings / Teleporter / Backup.
Auf dem neuen Gerät dann den Restore machen
 
Zuletzt bearbeitet:

Amosnet

Prophet

chaospir8

★★★★★-Oldie
Meine Frage aus #44 und wiederholt in #48 ist leider untergegangen. Vielleicht kann hier jemand was beitragen?

Und noch was:
Wie führt man ein Pi-Hole-Update durch?
1622145567634.png

Mir meldet die Software, dass es neuere Versionen gibt, aber wie macht man das am besten?
 

naranek10

Bekanntes Mitglied
Am besten du wählst dich über ssh auf den Pihole ein:

administrative Konsole

ssh pi@pihole (entsprechend deiner Gegebenheiten abändern)
Passwort
pihole -up

dann kannst du aber auch gleich das Raspberian Linux updaten:

im gleichen Fenster wie oben:

sudo -i
apt-get update
apt-get dist-upgrade
 

chaospir8

★★★★★-Oldie
OK, danke! Mit "Gesamt-Update" muss ich aber vorsichtig sein, weil auf meinem Einplatinenrechner noch einige andere Andwendungen neben dem Pi-Hole laufen.
 

naranek10

Bekanntes Mitglied
Das Gesamtupdate hält eben auch das komplette System aktuell. Ich habe in der Vergangenheit keine Probleme damit gehabt. Alternativ kannst Du vor dem Update das System herunterfahren (wenn es die Umstände zulassen) und eine Kopie der SD-Karte machen. Dann kannst du bei Problemen zum jeweiligen Stand zurückkehren.
 

chaospir8

★★★★★-Oldie
Ich habe dieses WE den Pihole als DNS aus meiner Fritzbox entfernt. Zu oft war's so, dass die Clients meldeten, offline zu sein, weil eben DNS-Auflösungen nicht funktionierten. Ich musste dann den Pihole durchstarten, damit es wieder funktionierte. Sowohl in den fritzbox- als auch in den Pihole-Logs war dazu nichts zu finden. Wenn also nicht mal google.com erreichbar ist und, wenn ich in der Fritte den manuell eingestellten DNS abschalte auf normale Einstellung ("vom Anbieter bla bla") vornehme und google.com sofort wieder erreichbar ist, ist es Schrott!
 

sw-stefan

Bekanntes Mitglied
Ich stimme ja zu, dass es Mist ist, wenn es nicht funktioniert... aber PiHole selbst ist imho kein Schrott und funktioniert bei mir seit mind. zwei Jahren ohne Probleme und händische Eingriffe (dank cronjob-Updates). Okay manchmal ist der Filter zu streng und irgendwelche mydealz-links oder so gehen nicht, aber dann kann man mit der Handy-App mal schnell den Filter für ne Minute abschalten und gut ist.
Das der Preis für weniger Werbung (auch auf den mobilen Geräten) - mehr Komplexität ist, ist halt so. Wenn Du mit der Werbung leben kannst: fein. Anderenfalls könnte man ja noch mal die PiHole und Systemlogs checken. Das Problem lässt sich sicher lösen.
 

chaospir8

★★★★★-Oldie
Ich habe kein Problem mit der Stränge der Pihole-Filter (nutze auch so eine Browser-Erweiterung, siehe hier in #46 vorgestellt), sondern, dass es sich komplett aufhängt/die Clients nicht ins Internet lässt, weil es eben dann kein Domains auflöst und nur ein Neustart des Dings Verbesserung bringt.

Ich kann aber tatsächlich nicht sagen, obs an Pihole oder an dem Einplatinenrechner in Summe liegt, auf dem mein Pihole läuft.
Allerdings weiß ich auch nicht, wie ich diesen Fehler eingrenzen kann.
 
@chaospir8
Ich hatte in der Vergangenheit dieselben Probleme, welche du beschrieben hast.
Bei mir hat der Austausch des Rapi geholfen. Habe mir den Raspi 4+ mit 8GB geholt, neu aufgesetzt mit Raspberry Pi OS und seit diesem Zeitpunkt keinerlei Ausfälle mehr. Router: Asus RT-68U (Asuswrt-Merlin).
 

BigAvalanche

Bekanntes Mitglied
@chaospir8: selbiges bei mir. Pihole hängt und dann keinerlei Domäins mehr erreichbar. Werde jetzt mal testen, ob es als Docker auf meiner Synology 918+ zuverlässiger läuft, als auf einem regulären Raspi.
 

dr_tommi

alter Oldie
Ich habe Pihole nicht auf einer Himbeere laufen sondern auf einem low-power-Minipc (fit-pc2) mit Linux.
Ich habe keine Ausfälle, bei mir läuft alles rund. Wenn ich mal merke dass die Filter zu heftig sind, dann kann ich den DNS-Server manuell umstellen.
Und die Filterlisten kann man ja auch manuell editieren.
Updates gibt es automatisch und alle sind glücklich.
Leider werden (noch) nicht alle Werbeeinblendungen unterdrückt. Gerade unter Facebook gibt es ab und zu ein paar Videos, die alle paar Minuten von nerviger Werbung unterbrochen werden.
 

sw-stefan

Bekanntes Mitglied
Ich habe kein Problem mit der Stränge der Pihole-Filter (nutze auch so eine Browser-Erweiterung, siehe hier in #46 vorgestellt), sondern, dass es sich komplett aufhängt/die Clients nicht ins Internet lässt, weil es eben dann kein Domains auflöst und nur ein Neustart des Dings Verbesserung bringt.

Ich kann aber tatsächlich nicht sagen, obs an Pihole oder an dem Einplatinenrechner in Summe liegt, auf dem mein Pihole läuft.
Allerdings weiß ich auch nicht, wie ich diesen Fehler eingrenzen kann.
Hat der Pi genug Strom?

Ich würde zur Fehleranalyse vtl. noch Cockpit (https://opensource.com/article/21/5/raspberry-pi-cockpit) installieren. Das ist so eine Management-Software, die u.a. auch die Logs schön darstellt und ggf. filtert.
 

RidJoker

Bekanntes Mitglied
Ich habe kein Problem mit der Stränge der Pihole-Filter (nutze auch so eine Browser-Erweiterung, siehe hier in #46 vorgestellt), sondern, dass es sich komplett aufhängt/die Clients nicht ins Internet lässt, weil es eben dann kein Domains auflöst und nur ein Neustart des Dings Verbesserung bringt.

Ich kann aber tatsächlich nicht sagen, obs an Pihole oder an dem Einplatinenrechner in Summe liegt, auf dem mein Pihole läuft.
Allerdings weiß ich auch nicht, wie ich diesen Fehler eingrenzen kann.
Das ist lustig - exakt das selbe Problem hatte ich auch, auf einem Raspi 2 mit Raspbian und Pi-Hole. Strom kann ich ausschließen, da es an einem Schalt-Netzteil mit 6A hängt. Die Kiste stirbt einfach ca. alle 2 Tage und ich hab noch nicht herausgefunden, was das Problem war (Hardware/Software) - da ich meine Infrastruktur mir CheckMk monitore, konnte ich genau sehen, wann er ausfiel. Dabei war die ganze Kiste tot, kein SSH, keine keepalive Pakete vom CheckMk Agent etc.

Hab ihn jetzt in einem Docker Container laufen (war eh der Plan, das zu tun) und seitdem ist ruhe
 

chaospir8

★★★★★-Oldie
Bei mir ist es ein Rock64-Platinchen. Und heute wieder war's nicht erreichbar ... aber dann auch "komplett", also auch nicht anpingbar. Es liegt also nicht am Pihole selbst. Strom hat das Ding jedoch ziemlich sicher genug, denn ich betreibe es mit dem mitgelieferten Netzteil.

Hmm. Es scheint so, als wenn ich hier wieder dieses alte Problem hätte: https://www.cc-community.net/threads/armbian-alle-zwei-tage-in-der-nacht-durchstarten-lassen.119025/, welches auf einem anderen "Computerchen" auftrat. Echt doof. Dabei laufen darauf nur Pihole und eine MariaDB-Datenbank für meine Kodi-Clients ...
 

hosit

Bekanntes Mitglied
Auffällig ist auf dem Raspi, dass der Speicherplatzbedarf immer größer wurde. Hatte Anfang des Jahres(?) die alte SD-Karte (4GB?) gegen was Größeres tauschen dürfen.
Aktuell nervt es nur noch. Laufend hängt beim Webzugriff irgendwas. Wenn man den Pihole in der Fritzbox "ausgraut" fluppt alles. Liegt also auch hier am Pihole.

Versorgt wird der Raspi vom USB-Port der Fritzbox. Könnte hier ein Engpaß sein.

Laut Webinterface des Pihole dümpelt die Auslastung immer bei deutlich unter 1% herum. Die CPU-Temperatur liegt bei etwa 42°C. Es sind 6 Filterlisten installiert und Pihole ist aktuell. Also nichts was in überfordern sollte.

Habe jetzt mal Cockpit installiert. Vielleicht fällt ja doch irgendwas auf...
 

hergi

Bekanntes Mitglied
Auffällig ist auf dem Raspi, dass der Speicherplatzbedarf immer größer wurde. Hatte Anfang des Jahres(?) die alte SD-Karte (4GB?) gegen was Größeres tauschen dürfen.
Aktuell nervt es nur noch. Laufend hängt beim Webzugriff irgendwas. Wenn man den Pihole in der Fritzbox "ausgraut" fluppt alles. Liegt also auch hier am Pihole.

Versorgt wird der Raspi vom USB-Port der Fritzbox. Könnte hier ein Engpaß sein.

Laut Webinterface des Pihole dümpelt die Auslastung immer bei deutlich unter 1% herum. Die CPU-Temperatur liegt bei etwa 42°C. Es sind 6 Filterlisten installiert und Pihole ist aktuell. Also nichts was in überfordern sollte.

Habe jetzt mal Cockpit installiert. Vielleicht fällt ja doch irgendwas auf...
Kann ich bei mir nicht so bestätigen. Läuft seit über einem Jahr problemlos auf einem RasPi 3 mit 16 GB Karte am USB Port der FritzBox 7590.
 

Gnmpf

Bekanntes Mitglied
Habs auf einem Raspi2 laufen seit 2Jahren, keine Probleme mit Hängern oder so, hört sich nach einem Treiber/HArdwareproblem an. Mal SD Karte klonen und dann Distribution updaten
 

gis

Bekanntes Mitglied
Meine Empfehlung ist das piHole in einem eigenem privaten Mini-DataCenter laufen zu lassen.

Hierfür habe ich mir folgende Hardware mit 32GB RAM und 512G SSD zugelegt:

https://www.amazon.de/HUNSN-Firewal...ewall,&qid=1629050858&s=computers&sr=1-3&th=1

Zu unterst läuft ein Proxmox als Basis für mein DC:

Proxmox: https://www.proxmox.com/de/

Die kostenlose Lizenz ist völlig ausreichend. In diesem VE wird zunächst eine Sophos UTM-9, ebenfalls in der kostenlosen Home Version installiert. Die beinhaltet neben Virenscanner, Intrusion Detection, allen Schnickschnack einer NextGeneration Firewall:

https://www.sophos.com/de-de/products/free-tools/sophos-utm-home-edition.aspx

In dieses Setup wird der piHole eingebunden und bei Bedarf können noch beliebige VMs gebootet werden. Ein Kali-Linux und vieles mehr läuft einigermaßen performant und dauerhaft in diesem VE.

Stromverbrauch liegt – mit Ausnahme von wenigen Spitzen – bei nur 10 Watt.
 

gis

Bekanntes Mitglied
In meiner beschriebenen Ausbaustufe ist es nicht ganz preiswert, aber es läuft auch auf vieeel günstigerer Hardware.
Ungetestet und nur vermutet, könnte es auch auf einem Raspberry mit 8GB lauffähig sein.


Da ich aber noch weitere VMs und Container permanent laufen lassen möchte, habe ich mir eine größere Ausbaustufe gegönnt.
 
Oben Unten