Software Frage Microsoft Edge startet plötzlich auf Domänen-PCs automatisch bei Anmeldung, ich finde aber keine verantwortlichen Autostart-Einträge

Bestatter

Schwarzfahrer
Seit wenigen Tagen startet auf einigen Domänen-PCs Microsoft-Edge als erstes bei der Anmeldung.
Weder im Autostart-Bereich des Task-Managers noch mit AutoRuns finde ich einen verantwortlichen Eintrag.
Auch in den GPO im Bereich "Edge" finde ich nichts, um den automatischen Start von Edge zu unterbinden.

Immerhin konnte ich das Problem soweit eingrenzen, dass nur die Clients betroffen sind, auf denen diverse Tools für Videokonferenzen installiert sind. (inzwischen widerlegt)
Die in AutoRuns gelisteten Einträge mit "Edge" sind 1:1 auf nicht betroffenen Clients vorhanden:
edge-autostart.png

An den Einstellungen der Konferenz-Tools wurde nichts geändert.
Wer kennt das Problem und vor allem die Lösung?

Alle Domänen-Clients sind Windows 10 Enterprise 20H2 mit aktuellem Patchstand.
 
Zuletzt bearbeitet:

golive

Bekanntes Mitglied
Sind Domänen PCs = Clients ?

Bei mir am Büro PC (Win10) kommt es regelmäßig vor, dass wenn ich vor dem Anmelden mit der Maus auf den Login Screen klicke (um den Rechner zu wecken) dass dann nach der Anmeldung der Browser aufgeht und mir Microsoft erklärt was ich gerade für ein tolles Bild gesehen habe ...

Eine "Mach das nicht Funktion" kenne ich leider nicht.

evtl hilft das : https://edvtraining.wordpress.com/2...sich-automatisch-beim-hochfahren-von-windows/
 

Bestatter

Schwarzfahrer
Alle PCs und Notebooks im Büro sind Domänen-Clients.
Der Standard-Browser ist der Firefox, auf den PCs mit Software für Videokonferenzen ist zusätzlich Chrome für z.B. Jitsi installiert.
Edge benutzt niemand, ist aber (leider) installiert.

Der EnableActiveProbing-Eintrag ist nicht Teil der Lösung!

Die Windows-Verison habe ich oben ergänzt.
 
Zuletzt bearbeitet:

dr_tommi

alter Oldie

Bestatter

Schwarzfahrer
Inzwischen sind auch Clients betroffen, auf denen keine Video-Konferenz-Tools installiert sind.

Die von @dr_tommi verlinkte Seite hatte ich auch schon gefunden und zunächst Teile der Vorschläge probiert, nur den Rest - leider alles erfolglos.
Der Punkt 5 dort ist übrigens falsch beschrieben! Nur aktivieren und negativ konfigurieren kann helfen, das Deaktivieren ist wie nicht konfigurieren.
Der Hinweis von @DrSnuggles bezieht sich auch auf diesen Punkt.

Die beiden Richtlinien
Code:
Zulassen, dass Microsoft Edge beim Starten von Windows und bei jedem Schließen von Microsoft Edge die Startseite und die Seite "Neue Registerkarte" startet und lädt
Zulassen, dass Microsoft Edge beim Starten von Windows, wenn sich das System im Leerlauf befindet und bei jedem Schließen von Microsoft Edge vorab gestartet wird
hatte ich zuerst in den lokalen Gruppenrichlinie auf meinem Testclient, danach auch über die GPO der Domäne aktiviert und negativ konfiguriert.
Anschließende mit gpupdate / force auf dem Client erzwungen und diesen auch neu gestartet.
Sobald ich aber mit RDP auf dem Client ankomme, ist Edge stets schon geöffnet.

Die Veränderungen an den Clients direkt vor der Edge-Erscheinung sind moderat, nur 3 Updates:
Paint.net 4.3.7
Chrome 97.0.4692.71
LibreOffice-7.2.5
 

EchtAtze

Bekannter Mitglied
Evtl. findest du ja etwas Rückschluss wenn du dir die "Command Line"-Spalte (im Tab "Details") im Task-Manager anschaust? Könnte ja sein, dass da Argumente verwendet werden, mit deren Hilfe/Kombination du in der Registry fündig wirst?
 

xsawa

Neues Mitglied
Hab auch das gleiche Problem:

Konfigurieren folgender 2 Gruppenrichtlinien haben nichts gebracht:
"Zulassen, dass Microsoft Edge beim Starten von Windows und bei jedem Schließen von Microsoft Edge die Startseite und die Seite „Neue Registerkarte“ startet und lädt“
„Zulassen, dass Microsoft Edge beim Starten von Windows, wenn sich das System im Leerlauf befindet und bei jedem Schließen von Microsoft Edge vorab gestartet wird“
 

xsawa

Neues Mitglied
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\EdgeUpdate\Clients\{56EB18F8-B008-4CBD-B6D2-8C97FE7E9062}\Commands\on-logon-autolaunch

AutoRunOnLogon = 0

Dann startetEdge nicht mehr
 

Bestatter

Schwarzfahrer
Nachdem ich daheim nun auch mit Edge zwangsbeglückt wurde und heute früh etliche Kollegen Beratungsbedarf bei der Edge-Ersteinrichtung :icon_funny: hatten, bin ich nach nochmaligem intensivem Testen dem Problem näher gekommen.

Verantwortlich ist in meinem Falle die
c:\Program Files (x86)\Microsoft\EdgeUpdate\MicrosoftEdgeUpdate.exe
in der Version 1.3.135.29, die auch durch 3 Einträge in der Aufgabenplanung gestartet wird.

Deaktiviere ich dort die beiden markierten
edge-autostart2a.png
welche bei Benutzeranmeldung und zu einer festen Zeit am Tag ausgeführt werden, ist der Begrüßungs-Edge nach ersten Tests Geschichte.

Da der Update-Prozess auch noch anders gestartet wird, wie im Screenshot zu sehen ist, gehe ich davon aus, dass diese Perle der Browser trotzdem aktuell bleibt.
Ich beobachte das mal ein paar Tage ...

--edit--
Ich kann die 2 Tasks der Aufgabenplanung zwar per Skript deaktivieren, aber der mit dem Appendix im Namen aus meinem Screenshot
Code:
SCHTASKS /change /TN "MicrosoftEdgeUpdateTaskMachineCore1d7408f5c9f61d" /disable
hat auf jedem Client einen anderen Appendix. :icon_knock:

Wie liest man noch mal automatisch die mit "MicrosoftEdgeUpdateTaskMachineCore" beginnenden Tasknamen eines Clients aus, um sie dann in ein Skript für alle Clients einzubinden ... :icon_confused:
 
Zuletzt bearbeitet:

Bestatter

Schwarzfahrer
Da sich mein letztes Posting in der Entstehung mit dem von @xsawa überschnitten hat, habe ich erst jetzt diesen Ansatz getestet:
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\EdgeUpdate\Clients\{56EB18F8-B008-4CBD-B6D2-8C97FE7E9062}\Commands\on-logon-autolaunch
AutoRunOnLogon = 0
Der funktioniert auch bei aktivierten Tasks in der Aufgabenplanung und {56EB18F8-B008-4CBD-B6D2-8C97FE7E9062} ist nach einem schnellen Check auf allen (?) Clients identisch.
Ich würde das momentan als beste Lösung ansehen.
 

Dorwyn

Bekanntes Mitglied
Trifft das nur Enterprise Versionen? Ich habe hier nur Pro im Einsatz und dieses Problem habe ich bislang noch nicht erlebt.
 

Sammo2k

Bekanntes Mitglied
Das passiert auch mit einer Windows 10 Pro 21H1 ohne Domäne (Screenshot). Ich habe jetzt den Key AutoRunOnLogon auf 0 gesetzt und bisher keinen erneuten Aufruf von Edge feststellen können. Auf unseren Clients der Domäne konnte ich keinen automatischen Start von Edge beobachten, obwohl AutoRunOnLogon hier auf 1 eingestellt ist.
1641977482494.png
 
Zuletzt bearbeitet:

Sammo2k

Bekanntes Mitglied
jetzt ist ja eine neue Edgeversion 97.0.1072.62 rausgekommen und siehe da:
1642162250421.png

der Key AutoRunOnLogon ist weg und Edge startet immer noch nicht automatisch.
 

GiveThatLink

Bekanntes Mitglied
MS Edge ist die neue "Webview", die früher vom IE bereitgestellt wurde. Ist das Absicht, dass ihr eine Sicherheitslücke nutzen wollt? Zumal der IE jetzt eh irgendwann wegfällt.
 
Oben Unten