Erledigt Linux Cinnamon (18.3 - Sylvia) Freigabe Sorge

m3rlin

Goose
Guten
Google, ohne wirklich Erkenntnis zu erlangen.

Ist-Zustand:
smbclient auf Windows-Freigabe(n) ohne Probleme
nemo (Desktop) Zugriff auf Windows Freigaben ohne Probleme

Nur ich kann keinen einzigen Ordner freigeben in Linux (siehe Themen-Titel):
»net usershare« gab den Fehler 255 zurück: net usershare add: cannot create tmp file /var/lib/samba/usershares/:tmpbrmPSZ

Mein Lappi (Win10) erkennt meinen Linux Rechner. Nur keine Freigaben.

Keine Freigaben, da ich nichts freigeben kann, wegen dieser andauernden Meldung.
»net usershare« gab den Fehler 255 zurück: net usershare add: cannot create tmp file /var/lib/samba/usershares/:tmpbrmPSZ

Meine Sorge ist: ich logge mich mit demselben Usernamen ein, Linux wie Windows

Ich google wirklich ohne Ende, ohne niemanden zu Last zu fallen. Soviel Antworten, diese
von Selbstverständlichkeiten eingehen. Eine weitere Antwort darauf führt nur noch mehr zu
Verwirrungen.


Bitte, Nerd in Sachen Linux.

Nachtrag:
Ich versuchte es über Desktop, meinen Ordner Bilder freizugeben. Via Terminal? Und oder.
Hilfe bitte..

Nachtrag 2:
-rw-rw-r-- 1 peter peter 102161 Apr 20 07:55 Andre.jpg
-rw-rw-r-- 1 peter peter 16298 Apr 21 08:21 comments.png
-rw-rw-r-- 1 peter peter 3689 Apr 21 02:04 TeamSpeak.png


Gruß M3rlin
 
Zuletzt bearbeitet:

m3rlin

Goose
Code:
smbd.service - LSB: start Samba SMB/CIFS daemon (smbd)
   Loaded: loaded (/etc/init.d/smbd; bad; vendor preset: enabled)
   Active: active (running) since Di 2018-04-24 13:14:07 CEST; 1h 15min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 1762 ExecStart=/etc/init.d/smbd start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/smbd.service
           ├─1777 /usr/sbin/smbd -D
           ├─1778 /usr/sbin/smbd -D
           └─1780 /usr/sbin/smbd -D

Apr 24 13:14:07 Peter-Pc systemd[1]: Starting LSB: start Samba SMB/CIFS daemon (smbd)...
Apr 24 13:14:07 Peter-Pc smbd[1762]:  * Starting SMB/CIFS daemon smbd
Apr 24 13:14:07 Peter-Pc smbd[1762]:    ...done.
Apr 24 13:14:07 Peter-Pc systemd[1]: Started LSB: start Samba SMB/CIFS daemon (smbd).
Ich suche und probiere (trial and error), sprich 0 Intelligenz. Heute sollte Cinnamon 18.3 Buch inkl DVD da sein.
Dank dir für deine Antwort :)
 

m3rlin

Goose
Gut soweit.
Was sagt den:
net usershare info --long
Leider gar nichts. - nur Prompt kam sofort zurück. Ich habe nur /etc/samba/smb.conf editiert:
WORKGROUP in ARBEITSGRUPPE

Restarts obligatorisch.

Hm. Ich bin doch Benutzer Peter, nicht root. Lappi loggt sich auch mit Peter ein. Sollte doch unwesentlich
sein. Beide [petpc]/petlappi gehören derselben ARBEITSGUPPE an. sda6 (Peter-Pc hat Cinnamon
so während der Installation gegeben), änderte ich gestern in ARBEITSGRUPPE (smb.conf) um.

Code:
[global]

## Browsing/Identification ###

# What naming service and in what order should we use to resolve host names
# to IP addresses
;   name resolve order = lmhosts host wins bcast

   usershare owner only = False

# Change this to the workgroup/NT-domain name your Samba server will part of
   workgroup = ARBEITSGRUPPE

# server string is the equivalent of the NT Description field
        server string = %h server (Samba, Ubuntu)

# Windows Internet Name Serving Support Section:
# WINS Support - Tells the NMBD component of Samba to enable its WINS Server
#   wins support = yes

# WINS Server - Tells the NMBD components of Samba to be a WINS Client
# Note: Samba can be either a WINS Server, or a WINS Client, but NOT both
;   wins server = w.x.y.z

# This will prevent nmbd to search for NetBIOS names through DNS.
   dns proxy = no

Ich habe auch TeamViewer installiert. Im Fall ...
 
Zuletzt bearbeitet:

spamwerbung

Bekanntes Mitglied
Ich hab jetzt keinen Plan wie das bei "Linux Cinnamon (18.3 - Sylvia)" genau gelöst ist, daher nur eine Anregung, wie ich sie von SAMBA bzw. smb.conf im Generellen kenne.

Wenn das deine gesamte smb.conf ist, kann das so nicht funktionieren. Du must in der smb.conf noch die Freigaben einstellen also unter welchem Namen du welchen Ordner du freigeben willst.

https://www.samba.org/samba/docs/current/man-html/smb.conf.5.html schrieb:
The following sample section defines a file space share. The user has write access to the path /home/bar. The share is accessed via the share name foo:

[foo]
path = /home/bar
read only = no

Sowas in der Art müsste noch in die smb.conf


Wie das jetzt bei "Linux Cinnamon (18.3 - Sylvia)" eingetragen wird weiß ich nicht. Ich vermute aber mal, dass net usershare add das in die smb.conf schreibt.
 

testi

Bekanntes Mitglied
Das dürfte die richtige Spur sein.
Das "net usershare info --long" gar nichts ausgibt, bestätigt das.

Hier mal ein Beispiel einer smb.conf:

# Global parameters [global]
workgroup = GSL
server string = %h server (Samba, Ubuntu)
server role = standalone server
map to guest = Bad User
obey pam restrictions = Yes
pam password change = Yes
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
unix password sync = Yes
syslog = 0
log file = /var/log/samba/log.%m
max log size = 1000
dns proxy = No
usershare allow guests = Yes
panic action = /usr/share/samba/panic-action %d
idmap config * : backend = tdb
 

m3rlin

Goose
Bin gerade unter Win10, einiges an Addons für Firefox und Chrome niederschreiben und kleineres. Will auf Linux
heimisch werden. So ruhig hab ich mein Rechner nie schnurren hören. Aber Chrome und FF können schon
die CPU hochtreiben, aber nur relativ. Speicher super, dass nur bei 4 GB

Nebensächlich:
2 Tiefpunkte innerhalb einer halben Stunde. Und ich bin kein Elefant
Axis of Awesome - 4 Four Chord Song

Ich hänge hier an (vielen herzl. Dank!)

So nebenbei:
innerhalb 8 Jahre hat meine Registry 200 MB erlangt. Ich bin nicht stolz darauf.
Deinstalliert ohne Ende. Ihr wisst es ja selbst. Gefühlte 0,1% Erfolg
 
Zuletzt bearbeitet:

m3rlin

Goose
Guten Morgen

Da gibt CC beim Absenden aus, solle zurück klicken und alles ist verloren. Ich tippe mit nur einer Hand (
Zeigefinger ). Warum wird in der Meldung nicht angezeigt, was das Problem ist? Zeitlebens nie passiert.
Und Copy&Paste wird wohl anders gelöst. Unter Terminal kann ich nur das markieren/kopieren, was
ich sehe. Ich kann zwar den ganzen Text markieren, nur der gesamte Inhalt wird nicht zwischengespeichert.
0 Erklärung (Google). Die Meta-Tasten etc. ausprobiert. = 0 Erfolg.

Zum wesentlichen:
Entschuldigt meine späte Antwort: Kurz nachdem ich hier geschrieben habe, fiel meine zweite FP aus: RAW.
Platte unter Linux und Windows wird erkannt. Unter Windows Smartdisk (komplett) drüber laufen lassen
Über einen halben Tag hat das mich gekostet. Dann die Formatierung. - Könnt ihr euch das erklären?
Es gab keine Stromspitzen. Auch kein Hard-Reset. Ich bin daher mehr als irritiert, auch wenn es nicht mit Windows/Linux
zusammenhängt. Ich hab Panik geschoben. Gibt es dafür eine Erklärung?

Eine Frage. Wenn ich im Terminal nano /etc/samba/smb.conf aufrufe; ich kann die gesamte Ausgabe markieren.
Copy & Paste gelingt nicht :( Warum?

Grr, jetzt lese ich, 1000 Zeichen Begrenzung. Das wirft mich um. Vor allem, wieviel Zeichen überschritten?
Warum macht ihr das Leben unnötig schwer? Ich gehe davon aus, dass ich mal ne Ausnahme bin.
Ich kann keine Text Datei einbinden, weil ich über home nicht hinweg auswählen kann. Moment. Ich habe
die Datei, als smb.conf, in meinem home Verzeichnis kopiert; hier ausgewählt:
Die hochgeladene Datei gehört nicht zu einem erlaubten Dateiformat.


Hier mal meine smb.conf: https://pastebin.com/EdsGu7hf

Nachtrag:
Es gab nichts anzupassen, wie ihr seht.
Terminal:
net usershare add Test /home/peter
net usershare add: cannot create tmp file /var/lib/samba/usershares/:tmp8CLXxQ

Nachtrag 2:
Zitat: Die Lösung steckt in den Verzeichnisrechten. Das Verzeichnis /var/lib/samba/usershares darf für "Alle anderen" keine Rechte haben und das Sticky-Bit muss gesetzt sein, also drwxrwx--T.

Nun wie? Nur wie? Sticky-Bit? Lesen lesen lesen. Sollte es daran liegen? Nerd ohne Ende. Wie setze ich diese? root? usershares:
drwxr-xr-x 2 root root 4096 Apr 21 21:12 .
drwxr-xr-x 5 root root 4096 Apr 23 21:12 ..

sudo chown $USERNAME /var/lib/samba/usershares/ -R
Look's like samba user is not in group users or someting like that.
Ohne Erfolg. Muss ich mich "Peter", ich bin nicht root, hinzufügen?
Macht das Mint 18.3 nicht schon während der Installation?

Eine vermeintliche Lösung ruft ein anderes Problem hervor :( Ich nehme
mal an, gerade Linux, ist die Lösung einfach. Nur ich hab diese nicht. Deswegen
bitte ich so sehr
 
Zuletzt bearbeitet:

spamwerbung

Bekanntes Mitglied
Aaaaalsooo, wie ich bereits vermutet habe fehlt die Angabe der "Shares Drives" in der smb.conf (soweit ich das sehen konnte). :)

Das Stricky-Bit wird glaub nur gebraucht, damit Dateien die man als "Peter" über die Freigabe abspeichert auch nur von "Peter" gelesen bzw. verändert werden können, das ist aber eigentlich gar nicht zwingend nötig. Es sei denn du willst über SAMBA auch die Netzanmeldung wie bei Active Directory machen und darüber Profile und solch Kram regeln.


Ich nutze SAMBA unter FreeBSD 11, daher können meine Ausführungen von dem wie das bei "Linux Cinnamon (18.3 - Sylvia)" gelöst ist abweichen!

1) Du musst zunächst einmal ein Verzeichnis anlegen oder angeben oder wissen, das du freigeben willst. Wenn du das gefunden hast, stellst du mittels chmod und chown ein, dass Peter Besitzer des Verzeichnisses ist und das User & Group rwx Rechte besitzen (chmod 775 & chown peter:root).

Also z.B.:
Code:
mkdir /samba
mkdir /samba/freigaben
chown -R peter:root /samba/freigaben
chmod -R 775 /samba/freigaben


2) Einen User zu SAMBA hinzufügen
Code:
smbpasswd -a peter


3) Nun musst du diese Freigabe in der smb.conf angeben, damit SAMBA dieses Verzeichnis als Netzfreigabe verwaltet.

Also vi (oder was auch immer du als Editor nutzt) und folgendes ganz am Ende einfügen:
Code:
[meinetollefreigabe]
path = /samba/freigaben
read only = no
browsable = yes
guest ok = no


3) SAMBA neu starten, keinen Plan wie das bei "Linux Cinnamon (18.3 - Sylvia)" gemacht wird. Bei FreeBSD geht das so:
service samba_server restart


Wenn du jetzt auf das Linux (oder wie auch immer der PC im Netzwerk heißt) mittels \\computername zugreifst, müsste da eine Freigabe "meinetollefreigabe" auftauchen in der man nun auch Dateien ablegen kann. Natürlich nur unter der Vorraussetzung, dass es einen User namens "Peter" auf dem Linux und im SAMBA gibt.


Du kannst dich ja mal hier durch ackern:
https://www.samba.org/samba/docs/current/man-html/smb.conf.5.html

Da steht alles, was man in der smb.conf einstellen kann, und ja das ist sehr viel Text. Läßt sich aber bei Linux nicht immer vermeiden. ;)
 

m3rlin

Goose
Guten Morgen

War erst vor 2 Stunden aufgestanden, daher die späte Antwort.

Herzlichen Dank f. deine Mühe. Ist-Situation: Windows erkennt zumindest schon mal meinen Rechner.
Irgendwo hab ich da was nicht beachtet. Ich kann zwar mein Ordner Bilder (wird mitinstalliert -> Persönlicher
Ordner) jetzt freigeben, Windows Lappi (über meinem Laptop) sieht nur die Freigabe nicht.
 

m3rlin

Goose
peter@Peter-Pc ~ $ ls -al Bilder
insgesamt 136
drwxrwxrwx 2 peter sambashare 4096 Apr 21 08:26 .
drwxr-xr-x 40 peter peter 4096 Apr 27 05:34 ..
-r--r--r-- 1 peter peter 102161 Apr 20 07:55 Andre.jpg
-r--r--r-- 1 peter peter 16298 Apr 21 08:21 comments.png
-r--r--r-- 1 peter peter 3689 Apr 21 02:04 TeamSpeak.png

peter@Peter-Pc: net usershare list
Bilder


Nur diesen Ordner möchte ich freigeben. Nur paar Stunden geschlafen, schon weiß ich nicht nicht mehr, wie ich
es geschafft habe, dass peter in sambashare auftaucht. Ist-Situation: Ich kann den Ordner Bilder auf dem Desktop
(mint Cinnamon 18.3) freigeben. Sinf nicht sichtbar auf Windows Seite
Ich muss immer wieder was falsch machen. :(

peter@Peter-Pc ~ $ chown -R peter:root samba/freigaben
chown: der Eigentümer von 'samba/freigaben' wird geändert: Vorgang nicht zulässig
peter@Peter-Pc ~ $ chown -R peter:root ./samba/freigaben
chown: der Eigentümer von './samba/freigaben' wird geändert: Vorgang nicht zulässig

peter@Peter-Pc ~ $ service samba_server restart
Failed to restart samba_server.service: Unit samba_server.service not found.

sudo /etc/init.d/samba restart
sudo /etc/init.d/smbd restart
 

vlintstoun

mit Glied
peter@Peter-Pc ~ $ chown -R peter:root samba/freigaben
chown: der Eigentümer von 'samba/freigaben' wird geändert: Vorgang nicht zulässig
peter@Peter-Pc ~ $ chown -R peter:root ./samba/freigaben
chown: der Eigentümer von './samba/freigaben' wird geändert: Vorgang nicht zulässig

sudo voransetzen!

Have fun
Vlintstoun

Edit: Warum mühst Du Dich auf der Kommandozeile ab? Dies festigt doch nur wieder den Ruf von Linux als Nerd- oder Hacker-OS :icon_mrgreen: Linux Mint bietet eine GUI für die Samba-Konfiguration. Ev musst Du diese aber zuerst noch installieren, am einfachsten geht das auf der Kommandozeile :icon_mrgreen:
Code:
sudo apt-get system-config-samba
 
Zuletzt bearbeitet:

m3rlin

Goose
sudo voransetzen!

Have fun
Vlintstoun

Edit: Warum mühst Du Dich auf der Kommandozeile ab? Dies festigt doch nur wieder den Ruf von Linux als Nerd- oder Hacker-OS :icon_mrgreen: Linux Mint bietet eine GUI für die Samba-Konfiguration. Ev musst Du diese aber zuerst noch installieren, am einfachsten geht das auf der Kommandozeile :icon_mrgreen:
Code:
sudo apt-get system-config-samba
sudo voransetzen!

Have fun
Vlintstoun

Edit: Warum mühst Du Dich auf der Kommandozeile ab? Dies festigt doch nur wieder den Ruf von Linux als Nerd- oder Hacker-OS :icon_mrgreen: Linux Mint bietet eine GUI für die Samba-Konfiguration. Ev musst Du diese aber zuerst noch installieren, am einfachsten geht das auf der Kommandozeile :icon_mrgreen:
Code:
sudo apt-get system-config-samba
Guten Abend zu euch allen

samba-system-config musste ich nachinstallieren. Interessanterweise habe ich Google zig fach genutzt. Kein Hinweis darauf. Alle sind von Terminal ausgegangen.
Gestern hat es geklappt. Linux hat mein Lappi erkannt. Und auch vom Lappi konnte ich auf Linux Freigaben zugreifen.

Seitdem beide Rechner aus waren, ich war bei einem Kumpel über Nacht, erkennt Linux nicht mal die eigenen Freigaben. Lappi kann aber auf Linux Freigaben zugreifen.
Linux erkennt nicht mal mehr die eigenen Freigaben /home/peter/Bilder /home/peter/Dokumente
Linux erkennt meine Windows Freigaben nicht mehr.
Laut system-config-samba ist alles in Ordnung. Habe auch nichts mehr daran geändert.

Google = 0 Erfolg

Code:
peter@Peter-Pc ~ $ sudo /etc/init.d//samba status
● nmbd.service - LSB: start Samba NetBIOS nameserver (nmbd)
   Loaded: loaded (/etc/init.d/nmbd; bad; vendor preset: enabled)
   Active: active (running) since Sa 2018-04-28 18:57:46 CEST; 5min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 3452 ExecStop=/etc/init.d/nmbd stop (code=exited, status=0/SUCCESS)
  Process: 3465 ExecStart=/etc/init.d/nmbd start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/nmbd.service
           └─3483 /usr/sbin/nmbd -D

Apr 28 18:57:46 Peter-Pc systemd[1]: Stopped LSB: start Samba NetBIOS nameserver (nmbd).
Apr 28 18:57:46 Peter-Pc systemd[1]: Starting LSB: start Samba NetBIOS nameserver (nmbd)...
Apr 28 18:57:46 Peter-Pc nmbd[3465]:  * Starting NetBIOS name server nmbd
Apr 28 18:57:46 Peter-Pc nmbd[3465]:    ...done.
Apr 28 18:57:46 Peter-Pc systemd[1]: Started LSB: start Samba NetBIOS nameserver (nmbd).
● smbd.service - LSB: start Samba SMB/CIFS daemon (smbd)
   Loaded: loaded (/etc/init.d/smbd; bad; vendor preset: enabled)
   Active: active (running) since Sa 2018-04-28 18:59:22 CEST; 4min 18s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 3853 ExecStop=/etc/init.d/smbd stop (code=exited, status=0/SUCCESS)
  Process: 3865 ExecStart=/etc/init.d/smbd start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/smbd.service
           ├─3881 /usr/sbin/smbd -D
           ├─3882 /usr/sbin/smbd -D
           └─3884 /usr/sbin/smbd -D

Apr 28 18:59:22 Peter-Pc systemd[1]: Stopped LSB: start Samba SMB/CIFS daemon (smbd).
Apr 28 18:59:22 Peter-Pc systemd[1]: Starting LSB: start Samba SMB/CIFS daemon (smbd)...
Apr 28 18:59:22 Peter-Pc smbd[3865]:  * Starting SMB/CIFS daemon smbd
Apr 28 18:59:22 Peter-Pc smbd[3865]:    ...done.
Apr 28 18:59:22 Peter-Pc systemd[1]: Started LSB: start Samba SMB/CIFS daemon (smbd).
Apr 28 19:01:19 Peter-Pc smbd[4059]: pam_unix(samba:session): session opened for user peter by (uid=0)
Apr 28 19:01:45 Peter-Pc smbd[4059]: pam_unix(samba:session): session closed for user peter
system-config-samba passt auch /etc/samba/smb.conf an.

Linux Neustart - Windows Lappi sieht Freigaben auf meinem Linux Rechner. Nur Problem besteht weiterhin:
Linux erkennt seine eigenen Freigaben nicht mehr
Linux erkennt keine Windows Freigaben mehr
Gestern war alles Top.

Code:
peter@Peter-Pc ~ $ smbclient -N -L \\petlappi\LappiE
WARNING: The "syslog" option is deprecated
Connection to petlappiLappiE failed (Error NT_STATUS_UNSUCCESSFUL)
peter@Peter-Pc ~ $ smbclient -N -L \\petlappi
WARNING: The "syslog" option is deprecated
Anonymous login successful
Domain=[PETLAPPI] OS=[Windows 10 Home 16299] Server=[Windows 10 Home 6.3]

    Sharename       Type      Comment
    ---------       ----      -------
Error returning browse list: NT_STATUS_ACCESS_DENIED
Anonymous login successful
Domain=[PETLAPPI] OS=[Windows 10 Home 16299] Server=[Windows 10 Home 6.3]

    Server               Comment
    ---------            -------

    Workgroup            Master
    ---------            -------
peter@Peter-Pc ~ $
Code:
peter@Peter-Pc ~ $ testparm /etc/samba/smb.conf
Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
WARNING: The "syslog" option is deprecated
Processing section "[homes]"
Processing section "[profiles]"
Processing section "[printers]"
Processing section "[print$]"
Processing section "[Dokumente]"
Processing section "[Bilder]"
Processing section "[Downloads]"
Loaded services file OK.
Server role: ROLE_STANDALONE

Press enter to see a dump of your service definitions

# Global parameters
[global]
    workgroup = ARBEITSGRUPPE
    server string = %h server (Samba, Ubuntu)
    server role = standalone server
    security = USER
    map to guest = Bad User
    obey pam restrictions = Yes
    pam password change = Yes
    passwd program = /usr/bin/passwd %u
    passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
    username map = /etc/samba/smbusers
    unix password sync = Yes
    syslog = 0
    log file = /var/log/samba/log.%m
    max log size = 1000
    name resolve order = lmhosts wins bcast host
    dns proxy = No
    usershare allow guests = Yes
    usershare owner only = No
    panic action = /usr/share/samba/panic-action %d
    idmap config * : backend = tdb


[homes]
    comment = Home Directories


[profiles]
    comment = Users profiles
    path = /home/samba/profiles
    create mask = 0600
    directory mask = 0700
    directory mode = 0700
    browseable = No


[printers]
    comment = All Printers
    path = /var/spool/samba
    create mask = 0700
    printable = Yes
    browseable = No


[print$]
    comment = Printer Drivers
    path = /var/lib/samba/printers


[Dokumente]
    comment = Dokumente
    path = /home/peter/Dokumente
    read only = No
    guest ok = Yes


[Bilder]
    comment = Bilder
    path = /home/peter/Bilder
    read only = No
    guest ok = Yes


[Downloads]
    comment = Downloads
    path = /home/peter/Downloads
    read only = No
    guest ok = Yes
peter@Peter-Pc ~ $

Code:
peter@Peter-Pc ~ $ smbclient -L localhost -U peter
WARNING: The "syslog" option is deprecated
Enter peter's password:
Domain=[ARBEITSGRUPPE] OS=[Windows 6.1] Server=[Samba 4.3.11-Ubuntu]

    Sharename       Type      Comment
    ---------       ----      -------
    homes           Disk      Home Directories
    print$          Disk      Printer Drivers
    Dokumente       Disk      Dokumente
    Bilder          Disk      Bilder
    Downloads       Disk      Downloads
    IPC$            IPC       IPC Service (Peter-Pc server (Samba, Ubuntu))
Domain=[ARBEITSGRUPPE] OS=[Windows 6.1] Server=[Samba 4.3.11-Ubuntu]

    Server               Comment
    ---------            -------
    PETER-PC             Peter-Pc server (Samba, Ubuntu)

    Workgroup            Master
    ---------            -------
    ARBEITSGRUPPE    
peter@Peter-Pc ~ $

Code:
less /var/samba/log.peter-pc:
[2018/04/27 16:23:11.283667,  0] ../source3/param/loadparm.c:3551(load_usershare_shares)
  load_usershare_shares: directory /var/lib/samba/usershares is not owned by root or does not have the sticky bit 't' set or is writable by anyone.

ls -al /var/lib/samba/usershares/
insgesamt 12
drwxr-xr-x 2 peter root 4096 Apr 28 18:50 .
drwxr-xr-x 5 root  root 4096 Apr 23 21:12 ..
???

:(
 
Zuletzt bearbeitet:

m3rlin

Goose
Guten Morgen

Ich habe es geschafft!

In beiden Richtungen. Klick auf Netzwerk unter Cinnamon (Schreibtisch/Desktop) öffnet alles, so wie ich mir das vorstelle.
Freigaben lassen sich nun auch darüber erstellen und werden sofort auf meinem Lappi als Freigabe erkannt. Als Anfänger rate ich zu system-samba-config.
Über das Terminal letztendlich kommt man nicht drüber hinweg. Ich weiß nicht mehr die Reihenfolge, wie ich vorgegangen bin. Etliche Webseiten
als Favoriten gespeichert.
Die Wikis erklären leider nur die "mächtige" Befehlsgewalt. Tolle Wurst, ohne Beispiele, für ein Nerd wie mich. Befehle --help unterm Terminal geben
dasselbe aus. Die Masse an Optionen/Argumente, da bin ich noch voerst völlig überfordert. "smbclient -L petlappi" genügt doch erst einmal. Und das fand ich in den
Weiten des Internets.

Das Hauptproblem an sich:
Auf meinem Desktop-Rechner läuft Windows 10 und Linux, getrennt für mich. Nix VM. Und starte ich erst unter Windows danach unter Linux, stehe ich
dann wieder vor ein Problem und nerve. :(

Gestern Abend Rechner aus, heute Morgen an, unter Linux gebootet, wie auch unter Linux gestern beendet. Alle Freigaben einsehbar
und Lappi wurde auch gleich erkannt. Starte ich unter Windows und später unter Linux, ist nichts mehr zu sehen. Kann nichts eingehängt werden.
Lösung: Linux patcht den Main Prozesser. Abhilfe schafft nur ein Reboot von Linux und alle Freigaben waren wieder da. :)

Noch eine Frage. Macht sich jemand über den Inhalt der versteckten Datei .xsession-errors Gedanken? Da gräuseln sich ja die Haare.

Beispiel:
Code:
.
.
.
sh: xdg-mime: command not found
sh: xdg-mime: command not found
sh: xdg-mime: command not found
sh: xdg-mime: command not found
sh: xdg-mime: command not found
sh: xdg-mime: command not found
sh: xdg-mime: command not found
sh: xdg-mime: command not found
sh: xdg-mime: command not found
sh: xdg-mime: command not found
sh: xdg-mime: command not found
sh: xdg-mime: command not found
sh: xdg-mime: command not found
sh: xdg-mime: command not found
sh: xdg-mime: command not found

(nemo:4302): Gtk-CRITICAL **: gtk_entry_set_text: assertion 'GTK_IS_ENTRY (entry)' failed

(nemo:4302): GLib-GIO-CRITICAL **: g_app_info_equal: assertion 'G_IS_APP_INFO (appinfo2)' failed

(nemo:4302): Gtk-CRITICAL **: gtk_widget_set_sensitive: assertion 'GTK_IS_WIDGET (widget)' failed

(nemo:4302): Gtk-CRITICAL **: gtk_widget_set_sensitive: assertion 'GTK_IS_WIDGET (widget)' failed

(nemo:4302): Gtk-CRITICAL **: gtk_file_chooser_set_filename: assertion 'GTK_IS_FILE_CHOOSER (chooser)' failed
sys:1: Warning: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

(nemo:4302): GLib-GIO-CRITICAL **: g_app_info_equal: assertion 'G_IS_APP_INFO (appinfo2)' failed

(nemo:4302): GLib-GIO-CRITICAL **: g_app_info_equal: assertion 'G_IS_APP_INFO (appinfo2)' failed

(nemo:4302): Gtk-CRITICAL **: gtk_entry_set_text: assertion 'GTK_IS_ENTRY (entry)' failed

(nemo:4302): GLib-GIO-CRITICAL **: g_app_info_equal: assertion 'G_IS_APP_INFO (appinfo2)' failed

(nemo:4302): Gtk-CRITICAL **: gtk_widget_set_sensitive: assertion 'GTK_IS_WIDGET (widget)' failed

(nemo:4302): Gtk-CRITICAL **: gtk_widget_set_sensitive: assertion 'GTK_IS_WIDGET (widget)' failed

(nemo:4302): Gtk-CRITICAL **: gtk_file_chooser_set_filename: assertion 'GTK_IS_FILE_CHOOSER (chooser)' failed

(nemo:4302): GLib-GIO-CRITICAL **: g_app_info_equal: assertion 'G_IS_APP_INFO (appinfo2)' failed
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.

(cinnamon:1653): St-WARNING **: Ignoring length property that isn't a number at line 1526, col 13

(cinnamon:1653): St-WARNING **: Ignoring length property that isn't a number at line 1526, col 13
xdg-mime ist aber installert. Seitdem ich gestern ein Hintergrund (Infinity War.jpg) als Hintergrund festgelegt habe.

Oder nen eigenes Thema draus machen? Lohnt sich nur nicht, wenn es keinen interessiert.


Schönen Feiertag wünsche ich euch. Von 100% schon vielleicht 2% geschafft, eher 1%. Linux ist gewaltig.


Gruß M3rlin

BTW: Ich postete auch im linuxmint Forum. - Ihr alle seid spitze. Jetzt kommen andere Dinge ran.
 
Zuletzt bearbeitet:
Oben Unten