Hackintosh und Grafikkarten-Darstellungsproblem

Dieses Thema im Forum "Mac" wurde erstellt von fotografikgj, 27 Juni 2009.

  1. fotografikgj

    fotografikgj Neues Mitglied

    Registriert seit:
    27 Juni 2009
    Beiträge:
    6
    Hallo, alles unter IDeneb_7 läuft wunderbar. Die Nvidia-Grafikkarten (habs mit 4 unterscheidlichen versucht) werden alle erkannt (Efi) - wie die gesamte andere Hardware auch- jedoch hab ich bei IDVD (8+9) keine Darstellung, der Bildschirm bleibt schwarz (Vorschau für DVD-Projekte). Das Selbe passiert bei Keynote und Pages (hier kommt jedoch, wenn ich den Play-Button drücke, die Fehlermeldung zu wenig VRAM-und das bei 1024MB;) Numehr bin ich ratlos, habe alles mir Mögliche versucht. Für Vorschläge schon jetzt herzlichen Dank:yo!!! Viele Grüße fotografikgj

    Asus P5LD2 Board
    Prozessor E7500
    Grafikkarte Nvidia 7950GX2 u.A.
    2 GB 800 Kingston Ram
    500GB Harddisk
  2. Steve-Urkel

    Steve-Urkel Team (Azubi ;-))

    Registriert seit:
    22 April 2001
    Beiträge:
    24.286
    AW: Hackintosh und Grafikkarten-Darstellungsproblem

    Die 1024MB hast du eben nicht einfach so zur Verfügung, sondern 2x512MB(das soll keine Haarspalterei sein, für OS X ist das nämlich je eine GraKa!) da es sich um einen "Verbund" von zwei Grafikkarten handelt.

    Darum, und falls du es noch nicht versucht hast, würde ich vorschlagen du versuchst es mit einem GraKa Treiber für die 7950(GX) (ohne 2) mit 512MB.
    Dabei handelt es sich, so meine ich mich zu erinnern, um eine alte G71 GPU für die es Treiber geben sollte. Wenn du die für 512MB nutzt sollte deine Meldung über zu wenig VRam hinfällig sein.


    Edit:
    Nur so eine Theorie da du die anderen Grafikkarten nicht benennst. :(
    fotografikgj sagt Danke.
  3. peppi911

    peppi911 Bekanntes Mitglied

    Registriert seit:
    31 März 2004
    Beiträge:
    1.062
    AW: Hackintosh und Grafikkarten-Darstellungsproblem

    Hi,

    was steht unter Apfel>über diesen Mac>weitere Informationen>Hardware>Grafik/Monitore>Quartz Extreme: xxxx

    Ich vermute das ist evtl. nicht unterstützt?
    Dann müsste vermutlich noch der/die Treiber mit der ID deiner Grafikkarte erweitert werden.

    VG,
    P
  4. fotografikgj

    fotografikgj Neues Mitglied

    Registriert seit:
    27 Juni 2009
    Beiträge:
    6
    AW: Hackintosh und Grafikkarten-Darstellungsproblem

    Hallo Stevi und Peppi, erstmal Danke für Eure schnellen Antworten und Vorschläge!!! Ich werds mit dem Treiber für die 7950(GX) mit 1GPU versuchen. Merkwürdig jedoch das es auch mit der, sorry hatte ich vergessen zu benennen, 6800XT (256mb), der 7600GTS (512MB) und der 7300GT (256MB) nicht klappt. So Resourcenfressend sollten die Programme nicht sein das die Voransicht nicht dargestellt wird...? Peppi Du hast recht, unter Quarz Extreme steht nichts, hab es gard nochmals mit der 6800XT versucht: Vidia GeForce 6800 XT:
    Chipsatz-Modell: nVidia GeForce 6800 XT
    Typ: Monitor
    Bus: PCIe
    PCIe-Lane-Breite: x16
    VRAM (gesamt): 512 MB
    Hersteller: NVIDIA (0x10de)
    Geräte-ID: 0x0141
    Versions-ID: 0x00a2
    ROM-Version: nVidia GeForce 6800 XT OpenGL Engine [EFI]
    Monitore:
    Monitoranschluss:
    Status: Kein Monitor angeschlossen
    X222W:
    Auflösung: 1680 x 1050 @ 60 Hz
    Farbtiefe: 32-Bit Farbe
    Core Image: Software
    Hauptmonitor: Ja
    Synchronisierung: Aus
    Eingeschaltet: Ja
    Quartz Extreme: Nicht unterstützt

    Wie erweitere ich die Identity? DAAANKE!!!:) fotografikgj
  5. peppi911

    peppi911 Bekanntes Mitglied

    Registriert seit:
    31 März 2004
    Beiträge:
    1.062
    AW: Hackintosh und Grafikkarten-Darstellungsproblem

    Deine ID ist dann offenbar 014110de.
    Ist bei mir schon etwas her, aber evtl. hilft dieser Thread:

    http://www.insanelymac.com/forum/index.php?showtopic=75246

    (mit anmeldung, hier der text)

    3-7 kannst Du vermutlich auslassen.
    Gruß,
    p
  6. fotografikgj

    fotografikgj Neues Mitglied

    Registriert seit:
    27 Juni 2009
    Beiträge:
    6
    AW: Hackintosh und Grafikkarten-Darstellungsproblem

    Top! Merci für alle Details!!! Wers versuchen, wahrscheinlich ist das zuviel für meinen Wissensstand...Ich dachte das Efi-tool bringt alle Infos mit. Kannst Du mir eine Grafikkarte vorschlagen mit der alles ohne Probleme läuft, sprich welche komplett via Efi eingebunden wird? Viele Grüße fgj
  7. peppi911

    peppi911 Bekanntes Mitglied

    Registriert seit:
    31 März 2004
    Beiträge:
    1.062
    AW: Hackintosh und Grafikkarten-Darstellungsproblem

    ...hier ist eine Liste, weiß nicht wie aktuell diese gehalten wird, wurde zwar 2009 aktualisiert, der Grakatest basiert aber auf 10.4.4...:

    supportet efi hw

    genannt werden da folgende:

    natürlich ohne Garantie;)

    (Evtl. hat guru _xtraa ja noch was einfacheres zur Installation parat wenn er über diesen Thread stolpert?!)

    Gruß,
    P
  8. Steve-Urkel

    Steve-Urkel Team (Azubi ;-))

    Registriert seit:
    22 April 2001
    Beiträge:
    24.286
    AW: Hackintosh und Grafikkarten-Darstellungsproblem

    Fast alles bis ausschließlich GTX GPUs läuft, teste doch erst mal die passenden Treiber.

    Nur als Beispiel läuft hier eine G9x GPU(8/9er Serie) ohne wenn und aber in einer Retail Installation auf einem P5Q.

    Wenn du dir den Installer von iDeneb anschaust wirst du sehen was integriert ist, und das ist eigentlich alles bis zur GTX die angeblich unter Snow Leopard ordentlich funktionieren soll.

    Die 7950GX2 läuft übrigens laut Insanelymac als Single Karte mit 512MB und NVinject ab 0.21 definitiv mit allen nötigen Funktionen! <- So gelesen, meine GX2 habe ich vor langer Zeit verkauft weshalb ein Test nicht möglich ist.
  9. fotografikgj

    fotografikgj Neues Mitglied

    Registriert seit:
    27 Juni 2009
    Beiträge:
    6
    AW: Hackintosh und Grafikkarten-Darstellungsproblem

    ...herzlichen Dank für Deine Bemühungen!!! Werde es weiter versuchen, ansonsten andere eine Grafikkarte anschaffen. Eine schöne Zeit und viele Grüße fgj
  10. fotografikgj

    fotografikgj Neues Mitglied

    Registriert seit:
    27 Juni 2009
    Beiträge:
    6
    AW: Hackintosh und Grafikkarten-Darstellungsproblem

    ...Steve Danke auch Dir für die guten Tipps, ich bin dahinter. Es wird schon schiefgehen!:) Viele Grüße fgj
  11. Steve-Urkel

    Steve-Urkel Team (Azubi ;-))

    Registriert seit:
    22 April 2001
    Beiträge:
    24.286
    AW: Hackintosh und Grafikkarten-Darstellungsproblem

    Kein Thema, hau rein und wenn alles nicht klappt poste einfach weiter deine Fragen, einfach aufgeben bzw. andere GraKa kaufen ist ...:yo
  12. peppi911

    peppi911 Bekanntes Mitglied

    Registriert seit:
    31 März 2004
    Beiträge:
    1.062
    AW: Hackintosh und Grafikkarten-Darstellungsproblem

    ...und ist zudem beim Hackintosh auch nicht zu empfehlen, da geht beim nächsten Update immer mal was schief, man muss sich schon damit beschäftigen andernfalls wird man nicht viel Spass damit haben.
    Am besten 2 bootfähige Partitionen, sonst kann es schnell recht nervig werden wenn er mal nicht bootet, dann kann eigentlich nichts schiefgehen....
    Good Luck!:yo
  13. fotografikgj

    fotografikgj Neues Mitglied

    Registriert seit:
    27 Juni 2009
    Beiträge:
    6
    AW: Hackintosh und Grafikkarten-Darstellungsproblem

    ...merci nochmals! Fein das Ihr so schnell behilflich wart, das ist weltklasse!!! Partitionen: Da hab ich bereits 4: 2x OSX (ideneb und kalyway), einmal Vista und 1x Win7x64. Noch ein sonniges weekend, viele Grüße fgj
  14. RidJoker

    RidJoker Bekanntes Mitglied

    Registriert seit:
    25 September 2001
    Beiträge:
    2.234
    AW: Hackintosh und Grafikkarten-Darstellungsproblem

    Moin - hab hier so einen ausgemustertes Lifebock s7110 von Fujistu Siemens und hab da mal iDeneb 1.5.1 10.5.7 draufgepackt. War alles kein Problem, nur Netzwerkkarte und Wlan Karte gehen nicht und die Graka hat kein aktiviertes Quartz Extreme.
    Da ich Hackintosh N00b bin - kann mir jemand mal kurz erläutern, wie ich das zum laufen bekomme?

    Laut HCL sollte das laufen. Achja, Graka ist ne Intel GMA 950
  15. xtraa_

    xtraa_ Serviervorschlag

    Registriert seit:
    28 Februar 2003
    Beiträge:
    14.988
    AW: Hackintosh und Grafikkarten-Darstellungsproblem

    Hey Rid, in kürze:

    Quelle

    Gibt also einiges zu tun, aber sollte dann soweit laufen. Ich glaub die intel 945GMA
    bekommst Du mit einer dsdt.aml zum laufen.

    Wenn allerdings WLAN aufgrund irgendwelcher Subvendor Spirenzchen nicht funzt, dann
    naja... installier lieber Ubuntu :D

    Gruß,

    xtraa
  16. RidJoker

    RidJoker Bekanntes Mitglied

    Registriert seit:
    25 September 2001
    Beiträge:
    2.234
    AW: Hackintosh und Grafikkarten-Darstellungsproblem

    Hey Xtraa,

    die HCL Liste hatte ich gesehen - leider steht da nicht die genaueren Schritte bei:

    Hmm - wozu brauch ich diese Modifications? Brauch ich sie überhaupt, wenn die Installation einwandfrei durchlief?

    hab jetzt aus /System/Library/Extensions alles gelöscht, was nach Intel 950 und 3100 kext aussah

    Scheint aber nichts bewirkt zu haben. Was bedeutet denn:

    Das System ansich ist sehr flott - Auflösung passt auch, nur hätte ich gerne noch Quartz Extreme aktiviert

    So, eigentlich viel wichtiger ist WLAN - hab hier zwar einen Haufen WLAN PCMCIA und USB -Sticks liegen, würde aber gerne die interne Intel 3945ABG zum laufen bringen:

    Was ist denn aus dem Projekt iwidarwin (http://code.google.com/p/iwidarwin/) geworden? Da gibts einen MacOS Treiber für die PROSet/Wireless 3945a/b/g OS X 10.5 (http://iwidarwin.googlecode.com/svn/trunk/iwi3945_new-osx10.5/iwi3945.dmg)

    Lässt sich auch installieren und anscheinend wird der kext auch beim Start geladen:

    Allerdings ist unter Systemeinstellungen -> Netzwerk nix weiter vorhanden
  17. xtraa_

    xtraa_ Serviervorschlag

    Registriert seit:
    28 Februar 2003
    Beiträge:
    14.988
    AW: Hackintosh und Grafikkarten-Darstellungsproblem

    Mit modifications meinen die einfach nur, da müssen noch ein paar kexte
    rein bzw. in den kexten die .plist angepasst werden, das ist alles. Ziemlich
    blöd ausgedrückt, ich musste auch zweimal hinschauen.

    Jo, ist aber trotzdem erstmal gut, damit sich das system nicht
    fälschlicherweise eine von denen grabbt und lädt.

    das gibt so einen ersteller für dsdt dinger, die packt man dann ins root.

    genau, das müsste - wenn - dann mit o.g. methode funzen.

    Was ist denn aus dem Projekt iwidarwin (http://code.google.com/p/iwidarwin/) geworden? Da gibts einen MacOS Treiber für die PROSet/Wireless 3945a/b/g OS X 10.5 (http://iwidarwin.googlecode.com/svn/trunk/iwi3945_new-osx10.5/iwi3945.dmg)

    Lässt sich auch installieren und anscheinend wird der kext auch beim Start geladen:

    Allerdings ist unter Systemeinstellungen -> Netzwerk nix weiter vorhanden[/quote]

    Ja, das ist in der Tat merkwürdig. Wie gesagt, es kann ein Subvendor sein,
    der da Ärger macht. Am besten mal unter Windows die genaue DeviceID
    und Vendor aufschreiben und die dann in die plist eintragen.

    Vielleicht auch mal im terminaleingeben:

    >ifconfig en0 down
    und dann
    >ifconfig en0 up

    Vielleicht braucht er nur eine Starthilfe.
  18. RidJoker

    RidJoker Bekanntes Mitglied

    Registriert seit:
    25 September 2001
    Beiträge:
    2.234
    AW: Hackintosh und Grafikkarten-Darstellungsproblem

    eHi xtraa,

    kannst Du das mit dem dsdt Patcher mal genauer erläutern? Was ist das, was macht es und wie bekomm ich Quartz Extreme damit zum laufen?

    Ansonsten - die Kupfer Nic geht, Wlan geht auch mit einem extern USB Stick - allerdings hab ich noch ein Auge auf das Project Camphor

    Im Prinzip würde es mir jetzt reichen, wenn ich diese )§"R$%&"/& Graka im Quartz Extreme Modus zu laufen bekomme - alles andere bekomm ich irgendwie selber hin. Nur scheinen die Infos spärlich. Meistens findet man Infos zur Intel GMA 950, die aber inkompatibel zu meiner eingebauten 945 sein soll.

    Achja - Triple Boot (Windows7 + MacOS + Ubuntu) läuft fluffig - allerdings erstmal nur mit dem 7 Bootloader - mal sehen - eigentlich würde ich ja lieber Chameleon bevorzugen - sieht schicker aus
  19. peppi911

    peppi911 Bekanntes Mitglied

    Registriert seit:
    31 März 2004
    Beiträge:
    1.062
    AW: Hackintosh und Grafikkarten-Darstellungsproblem

    Schmeiss doch mal die hier geposteten Treiber rein.
    Gruß,
    P
  20. RidJoker

    RidJoker Bekanntes Mitglied

    Registriert seit:
    25 September 2001
    Beiträge:
    2.234
    AW: Hackintosh und Grafikkarten-Darstellungsproblem

    Hi Peppi,

    hmm - irgendwas bewirkt der Treiber - Auflösung kann ich jetzt ändern und auch die externe Monitorerkennung geht - but still no Quartz Extreme :-(

    Vendor und Device ID stimmt auch (8086 und 27a2)
  21. xtraa_

    xtraa_ Serviervorschlag

    Registriert seit:
    28 Februar 2003
    Beiträge:
    14.988
    AW: Hackintosh und Grafikkarten-Darstellungsproblem

    Hi,

    die seite ist grad am basteln, aber wenn sie wieder geht:

    For anyone with the GMA945 that is having problems with QE/CI follow the instructions here:

    http://forum.osx86scene.com/viewtopic.php?f=3&t=3507&p=23937

    Ansonsten lad Dir noch mal die OSX86Tools runter, da ist ganz unten ein Button, neue Treiber
    installieren. Dabei lädt er die automatisch runter und checkt im System deine hardware.

    http://code.google.com/p/osx86tools/

    Gruß,

    xtraa
  22. RidJoker

    RidJoker Bekanntes Mitglied

    Registriert seit:
    25 September 2001
    Beiträge:
    2.234
    AW: Hackintosh und Grafikkarten-Darstellungsproblem

    lol - immer noch down for maintenance.

    Mittlerweile hab ich QuartzGL aktiviert (über dieses OSX86Tools) - aber immer noch kein Quart Extreme - hmm..scheisse.

    mit dem Ton hab ich auch noch so meine Problemchen