Erledigt Gnome3 - Verknüpfungen hinzufügen

Dieses Thema im Forum "Linux" wurde erstellt von silentreader, 11 Juni 2011.

  1. silentreader

    silentreader Bekanntes Mitglied

    Registriert seit:
    11 Januar 2007
    Beiträge:
    1.027
    Hallo,

    ich habe meinem Vater ein neues Fedora 15 System mit Gnome3 aufgesetzt. Bis auf ein paar Kleinigkeiten läuft alles hervorragend.

    Leider haben sich nach der Installation von LibreOffice keine Verknüpfungen zu den Programmen in Aktivitäten unter Anwendungen angelegt. Wie kann man diese Verknüpfungen manuell anlegen? Google hat leider nicht geholfen - wahrscheinlich falsche Suchbegriffe...

    Danke im Voraus!
  2. Tucker

    Tucker OSS117

    Registriert seit:
    7 Januar 2002
    Beiträge:
    305
    AW: Gnome3 - Verknüpfungen hinzufügen

    Hm. LibreOffice über yum installiert?

    Code:
    yum groupinstall "Office/Productivity"
    Ansonsten die Starterfiles von Hand anlegen:

    Im Verzeichnis ~/.local/share/applications Dateien erstellen (Endung .desktop)

    Zum Beispiel:

    netbeans.desktop
    Code:
    [Desktop Entry]
    Encoding=UTF-8
    Name=NetBeans IDE 7.0
    Comment=The Smarter Way to Code
    Exec=/bin/sh "/home/micha/bin/netbeans-7.0/bin/netbeans"
    Icon=/home/micha/bin/netbeans-7.0/nb/netbeans.png
    Categories=Application;Development;Java;IDE
    Version=1.0
    Type=Application
    Terminal=0
    
    oder

    libreoffice-writer.desktop
    Code:
    Version=1.0
    Terminal=false
    Icon=writer
    Type=Application
    Categories=Office;X-Red-Hat-Base;X-SuSE-Core-Office;X-MandrivaLinux-Office-Wordprocessors;
    Exec=libreoffice --writer %U
    MimeType=application/vnd.oasis.opendocument.text;application/vnd.oasis.opendocument.text-flat-xml;application/vnd.oasis.opendocument.text-template;application/vnd.oasis.opendocument.text-web;application/vnd.oasis.opendocument.text-master;application/vnd.sun.xml.writer;application/vnd.sun.xml.writer.template;application/vnd.sun.xml.writer.global;application/vnd.stardivision.writer;application/msword;application/vnd.ms-word;application/x-doc;application/rtf;text/rtf;application/vnd.wordperfect;application/wordperfect;application/vnd.openxmlformats-officedocument.wordprocessingml.document;application/vnd.ms-word.document.macroenabled.12;application/vnd.openxmlformats-officedocument.wordprocessingml.template;application/vnd.ms-word.template.macroenabled.12;
    Name=LibreOffice  Writer
    Name[pt_BR]=LibreOffice  Writer
    GenericName=Word Processor
    GenericName[en]=Word Processor
    Comment=Create and edit text and graphics in letters, reports, documents and Web pages by using Writer.
    Comment[en]=Create and edit text and graphics in letters, reports, documents and Web pages by using Writer.
    InitialPreference=5
    Genaueres hier:

    http://developer.gnome.org/integration-guide/stable/index.html.en

    oder spezieller:
    http://developer.gnome.org/integration-guide/stable/desktop-files.html.en
  3. silentreader

    silentreader Bekanntes Mitglied

    Registriert seit:
    11 Januar 2007
    Beiträge:
    1.027
    AW: Gnome3 - Verknüpfungen hinzufügen

    Jep, über yum installiert. Allerdings nicht über groupinstall.

    Vielen Dank für die Hinweise. Werde die Starterdateien so von Hand anlegen, das ist ja kein Problem. Ich wusste nur nicht wo die Verknüpfungen hin müssen.

    Gebe bescheid, ob es geklappt hat...
  4. silentreader

    silentreader Bekanntes Mitglied

    Registriert seit:
    11 Januar 2007
    Beiträge:
    1.027
    AW: Gnome3 - Verknüpfungen hinzufügen

    Ich habe gerade versucht nach den Beispielen eine Verknüpfung für LibreOffice-Writer zu erstellen. Leider hat es aber nicht funktioniert. Ich habe das Beispiel noch um "Encoding=UTF-8" ergänzt und es unter ~/.local/share/applications und /usr/share/applications ausprobiert (das habe ich den o. g. Links entnommen). Der Dateiname ist zum Testen einfach lwriter.desktop.

    Ich habe mich mehrfach neu angemeldet und auch das System neu gestartet. Leider bekomme ich kein Startersymbol angezeigt.

    Was läuft bzw. mache ich falsch?

    //Edit:

    Ich habe eben probiert, wie oben beschrieben per
    Code:
    yum groupinstall "Office/Productivity"
    zu installieren. Nun passt alles :)

    Vielen Dank!