Linux Frage Frage zu fstab

FaXe

KühlesBlondes
Hallo zusammen,

Ich habe ein Raspberry Pi II mit Raspbian Wheezy drauf. Ich möchte nun auf meinen NasServer vom PI aus,zugreifen können. Alle Versuche den Nasserver in die fstab einzubauen haben gescheitert. Vllt wißt Ihr ja eine Lösung.
Danke
pi =192.168.178.XX
Nas= 192.168.178.30
 

ibinsfei

Team (Technik) - BOFH
Mitarbeiter
Beispiele:

//192.168.178.30/sharename /mountpoint smbfs user=username,credentials=/etc/samba/cred,iocharset=iso8859-15,rw,file_mode=0775,dir_mode=0775
//192.168.178.30/sharename2 /mountpoint2 cifs user=username2,credentials=/etc/samba/cred2,iocharset=iso8859-15,rw,file_mode=0775,dir_mode=0775

credentials-file:
/etc/samba/cred:
username=username
password=password
 

Hans Bear

unsichtbar
@ibinsfei ist cif und smb nicht das selbe?

@FaXe schau mal in die logs. (/var/log/) da ist warscheinlich des rätsels lösung zu finden.
kannst du die freigabe manuell mounten? wenn du das mal versuchst wird der fehler warscheinlich sogar
auf der konsole angezeigt.wenn das dann klappt dann kannst du es in der fstab verewigen.
mount -t cifs //192.168.178.xx/video /media/nas

EDIT: omg.. da war n fehler in der befehlszeile
 
Zuletzt bearbeitet:

ibinsfei

Team (Technik) - BOFH
Mitarbeiter
@Hans Bear
CIFS ist eine Weiterentwicklung von SMB.
ich hatte es versucht smbmount //192.168.178.xx/video /media/nas cifs deflauts
smbmount ist ein Kommandozeilentool, das ist nicht der Eintrag für /etc/fstab. Wenn du keine Anmeldung am der NAS für einen Sambamount brauchst, kannst du auch den Eintrag "//192.168.178.xx/video /media/nas cifs defaults" versuchen.
 

FaXe

KühlesBlondes
@ibinsfei ist cif und smb nicht das selbe?

@FaXe schau mal in die logs. (/var/log/) da ist warscheinlich des rätsels lösung zu finden.
kannst du die freigabe manuell mounten? wenn du das mal versuchst wird der fehler warscheinlich sogar
auf der konsole angezeigt.wenn das dann klappt dann kannst du es in der fstab verewigen.
mount -t cifs //192.168.178.xx/video /media/nas

EDIT: omg.. da war n fehler in der befehlszeile
also mit sudo mount -t cifs //192.168.178.xx/video /media/nas

kann ich es händisch mounten, er fragt nach einen Password, was das Nas auch verlangt.

//192.168.178.30/video on /media/video type cifs (rw,relatime,vers=1.0,cache=str ict,username=root,domain=NAS-SERVER,uid=0,noforceuid,gid=0,noforcegid,addr=192.1 68.178.30,unix,posixpaths,serverino,mapposix,acl,rsize=61440,wsize=65536,actimeo

da zeigt er mir das nun an
 

ibinsfei

Team (Technik) - BOFH
Mitarbeiter
Dann versuche es doch mit dem Eintrag, den ich ober schon beschrieben habe:

//192.168.178.30/viedeo /media/nas cifs user=root,credentials=/etc/samba/cred,iocharset=iso8859-15,rw,file_mode=0775,dir_mode=0775

nicht vergessen des File /etc/samba/cred zu erzeugen
 

Last Boyscout

Blindenstockträger
Komme ich nochmal .. sowas hat mich auch schon zur Verzweiflung getrieben. Jetzt nehme ich autofs dafür, damit klappt es bei mir (Ich connecte mich gleich mit dem Benutzer des Servers drauf, erspart mir den Rechtekram, brauch ich nicht im Heimnetz)

Inhalt automaster:
/home/"User"/"Mountpoint"

Inhalt auto.share z.B:
"Beispiel" -fstype=cifs,uid=1000,gid=1000,user="UservomServer",password="PassvomUserdesServers",rw,file_mode=0664,dir_mode=0775 ://"IpAdressedesServersimHomenetz"/"NamedesVerzeichnissunterMountpoint, hier dann Beispiel"

Das Verzeichniss "Mountpoint" musst Du anlegen.
Die Verzeichnisse "darunter" nicht, die werden nur in der auto.share eingetragen und dann durch autofs gemountet

Hoffe es ist verständlich, bin nicht so der große Schreiber
 

ibinsfei

Team (Technik) - BOFH
Mitarbeiter
Ich habe es gerade mal auf meinem raspel mit meinem NAS probiert und es geht problemlos:
Code:
root@raspberrypi:/etc/samba# uname -a
Linux raspberrypi 3.18.7+ #755 PREEMPT Thu Feb 12 17:14:31 GMT 2015 armv6l GNU/Linux
root@raspberrypi:/etc/samba# grep cifs /etc/fstab
//192.168.101.1/Myth    /media/video    cifs    user=root,credentials=/etc/samba/lscred
root@raspberrypi:/etc/samba# mount /media/video/
root@raspberrypi:/etc/samba# mount|grep cifs
//192.168.101.1/Myth on /media/video type cifs (rw,relatime,vers=1.0,cache=strict,username=root,domain=LS-QVL843,uid=0,noforceuid,gid=0,noforcegid,addr=192.168.101.1,file_mode=0755,dir_mode=0755,nounix,serverino,rsize=61440,wsize=65536,actimeo=1)
root@raspberrypi:/etc/samba# cat lscred
username=root
password=********
 

ibinsfei

Team (Technik) - BOFH
Mitarbeiter
@Last Boyscout
davon gehe ich aus, wenn ich diesen Post lese:
also mit sudo mount -t cifs //192.168.178.xx/video /media/nas

kann ich es händisch mounten, er fragt nach einen Password, was das Nas auch verlangt.

//192.168.178.30/video on /media/video type cifs (rw,relatime,vers=1.0,cache=str ict,username=root,domain=NAS-SERVER,uid=0,noforceuid,gid=0,noforcegid,addr=192.1 68.178.30,unix,posixpaths,serverino,mapposix,acl,rsize=61440,wsize=65536,actimeo
 

Hans Bear

unsichtbar
zur not einfach quick and dirty den befehl in die rc.local rein.
wie das dann mit dem login geht weiß ich nicht auswendig aber auch das müsste doch mit ner credenials-datei
zu lösen sein.

@FaXe hast du vielleicht die "xx" vergessen zu ersetzen?
 

Last Boyscout

Blindenstockträger
Lese mal das sorgfältig durch:

https://wiki.ubuntuusers.de/samba_client_cifs

Was mir das vor allem auffällt:

Systemweites Automount
Im günstigsten Falle werden die Freigaben bereits beim Systemstart automatisch eingebunden, wenn man beim Eintrag in fstab die Option noauto vermeidet (also die Standard-Einstellung auto verwendet) und einen Mountpunkt wählt, der Besitz von root ist. Bedingung ist allerdings, dass die Netzwerk-Verbindung bereits beim Abarbeiten von fstab zur Verfügung steht, was keineswegs immer der Fall sein muss.
Deswegen habe ich das damals glaube ich über AUTOFS gemacht
 
Oben Unten