Debian Linux: Installationsprobleme

ÐrBen™

٩(͡๏̯͡๏)۶
Habe das Paket kernel-headers-2.6.8-1-386 nachinstalliert, die kernel-headers-2.6.8-1 sind angeblich auf dem aktuellen Stand vorhanden. Leider erhalte ich immer noch die gleiche Fehlermeldung beim make usb buildonly=debug. Was nun?

edit: Um endlich mal voranzukommen, wollte ich jetzt den NdsiWrapper installieren, um einfach den Windows-Treiber für meinen USB-WLAN-Adapter nutzen zu können. Und siehe da, im zugehörigen Wiki findet sich eine Lösung für mein Problem mit dem atmelwlandriver:
Code:
    * Make sure there is a link to the kernel source from the modules directory. /lib/modules/VERSION/build should be a link to the kernel source, where VERSION is the version of the kernel you are running. If there is no link, you'll get an error at the make install step. To create a link, assuming the kernel sources are present, use the command

ln -s /usr/src/linux-<kernel-version> /lib/modules/VERSION/build
Bin gespannt, ob das klappt.
 

ÐrBen™

٩(͡๏̯͡๏)۶
Das oben hat funktioniert, aber mehr als einen Schritt auf einmal darf es anscheinend nicht weitergehen. :argh:

Ich habe jetzt das Problem, daß nach einem iwconfig keine WLAN Schnittstelle angezeigt wird. Laut Treiberanleitung sollte ich eine atm0-WLAN-Schnittstelle haben, stattdessen steht überall nur "no wireless extensions."

In der Treiberanleitung ist zu lesen, eine Ursache für diese Problem könnte fehlende WLAN-Unterstützung im Kernel sein, Laut uname -r habe ich den 2.6.8-1-386 Kernel installiert. Wie kann ich herausfinden, ob bei meinem aktuell installierten Kernel WLAN-Unterstützung aktiviert ist?
 

Duchemin

Balls Of Steel
Da du den Standard 2.6.8-1-Kernel von Debian einsetzt, dürfte wohl die WLAN-Funktionalität schon einkompiliert sein.

Gehe mal in /boot und dort gibt es eine Datei "config-<Kernel-Vers.>"

Dann gib mal ein "cat config-2.6.8-1-386 | grep WIRELESS" und "cat config-2.6.8-1-386 | grep NET_RADIO".

Bei beiden Befehlen muss die Ausgabe auf "=y" (yes) enden, dann ist auf jeden Fall die WLAN-Funktionalität einkompiliert.


Deswegen tippe ich eher auf ein nicht sauber geladenes Modul deines neu kompilierten Treibers.

Mach mal eine neue Konsole auf und tippe dort ein "tail -f /var/log/syslog", damit du eine kontinuierliche Ausgabe der System-Ausgaben hast, lade in einer anderen Konsole das Treiber-Modul mit "modprobe <Modulname>" und beobachte in der ersten Konsole die System-Ausgaben.

Alle geladenen Module kannst du mit "lsmod" anzeigen lassen.

cu,

D.

PS: Hau dir Windows XP MCE drauf. Dann hast du denn ganzen Stress nicht.
 

ÐrBen™

٩(͡๏̯͡๏)۶
Duchemin schrieb:
Gehe mal in /boot und dort gibt es eine Datei "config-<Kernel-Vers.>"
Dann gib mal ein "cat config-2.6.8-1-386 | grep WIRELESS" und "cat config-2.6.8-1-386 | grep NET_RADIO".
Bei beiden Befehlen muss die Ausgabe auf "=y" (yes) enden, dann ist auf jeden Fall die WLAN-Funktionalität einkompiliert.
Du hast Recht, beides wurde mit "Y" bestätigt.

Duchemin schrieb:
Mach mal eine neue Konsole auf und tippe dort ein "tail -f /var/log/syslog", damit du eine kontinuierliche Ausgabe der System-Ausgaben hast, lade in einer anderen Konsole das Treiber-Modul mit "modprobe <Modulname>" und beobachte in der ersten Konsole die System-Ausgaben.
Alle geladenen Module kannst du mit "lsmod" anzeigen lassen.
Leider bin ich nicht in der Lage, unter den von lsmod ausgegebenen Modulen das WLAN-Treiber-Modul zu finden, nichts passt auch nur halbwegs. Einziges Indiz für den Treiber ist folgendes: Wenn ich den USB-WLAN-Adapter eingesteckt habe, kann ich per lsusb ein Gerät namens "Atmel Corp. ... 802.11b Adapter" sehen, also scheint der Treiber ja schon irgendwie mit dem USB-Adapter im Zusammenhang zu stehen. Kann ich dann davon ausgehen, daß der Treiber auch geladen wurde?

Duchemin schrieb:
PS: Hau dir Windows XP MCE drauf. Dann hast du denn ganzen Stress nicht.
Du kannst Dir nicht vorstellen, wie oft ich Laufe des Installations-Terrors die WinXP-CD in der Hand hatte. Die Media-Center-Edition wäre vielleicht eine Alternative gewesen, aber der MLDonkey läuft auf der Kiste so rund, da muß ich diesen Kampf um jeden Preis zu Ende führen...
 

Duchemin

Balls Of Steel
Kenne mich leider mit dem Atmel USB-WLAN Geraffel auch nicht aus...

Was ist denn die genaue Ausgabe von "tail -f /var/log/syslog", wenn du den USB-Adapter an den Computer anschliesst?

Und welche Untermodule sind anschliessend dem Modul "usbcore" unter "lsmod" zugeordnet (stehen in der gleichen Zeile dahinter)?

cu,
D.
 

ÐrBen™

٩(͡๏̯͡๏)۶
Also wenn ich das Teil eingesteckt habe, erscheint nur die Meldung:
Code:
localhost kernel: usb 3-2: new full speed USB device using adress 3"
hinter usb-core steht:
Code:
usbhid, uhci_hcd, ehci_hcd
und wie gesagt erscheint nach dem Einstöpseln unter lsusb ein Gerät namens "Atmel Corp. ... 802.11b Adapter".
 

Duchemin

Balls Of Steel
Das ist ein ganz klares Zeichen dafür, das zwar der USB-Adapter am USB-Bus erkannt wird, aber definitv kein Treibermodul nachgeladen wird.

Das Paket "hotplug" ist ja installiert, oder?

Was passiert, wenn du das neu kompilierte Atmel-Modul per Hand mit "modprobe <modulname>" nachlädst? (Ausgaben in /var/log/syslog beachten!)

---------------------------------------

Ich will dir ja den "Spass" an deiner Debian-Installation nicht verderben, aber ich würde mir als Newbie an deiner Stelle wirklich mal Mandrake, SuSE oder Fedora Core anschauen. Die sind wesentlich newbiefreundlicher als Debian und man muss bei weitem nicht so viel Hand anlegen wie bei Debian... (und wenn es doch weiterhin Debian sein sollte, dann entsprechende userfreundliche Distris wie Xandros oder Ubuntu.)

cu,

D.
(für den es als ordentliches und modernes Desktop-Betriebssystem für x86s nur Windows XP -u.U. mit Abstrichen Win2000- gibt.)

PPS: Ja ich weiss... Eseltreiben unter Linux mit mldonkey ist eine feine Sache...Aber um die Eignung als Server brauchen wir bei Linux ja nicht zu streiten...
 

Nauticat33

Bekanntes Mitglied
Hm, ich steige ja ein wenig spät in die Diskussion ein und hab nur diagonal gelesen... Hast du den Kernel-Patch für 2.6er Kernels einkompiliert?
--> http://atmelwlandriver.sourceforge.net/downloads.html

Außerdem:
Atmel schrieb:
Support for 2.6 kernels, especially regarding those provided by some fresh distributions, has been improved.
Note that you will need quite recent version of Wireless Tools to use some features of the drivers. Using the latest version of the tools is recommended. Some features might also require latest beta version.
Hast du die wireless-tools aus dem debian-tree mit apt-get installiert? Dann könnten sie vielleicht zu alt sein?

Ansonsten teile ich Duchemins Meinung, daß der Treiber schlicht nicht geladen wird. Hast du den Kernel neu kompiliert und wird auch der richtige Kernel beim Bootvorgang geladen?

Gruß,
nauticat
pinguinisierter Eseltreiber
 

ÐrBen™

٩(͡๏̯͡๏)۶
Duchemin schrieb:
Das ist ein ganz klares Zeichen dafür, das zwar der USB-Adapter am USB-Bus erkannt wird, aber definitv kein Treibermodul nachgeladen wird.

Das Paket "hotplug" ist ja installiert, oder?
Yup, ist laut apt-get in aktueller Version vorhanden.

Duchemin schrieb:
Was passiert, wenn du das neu kompilierte Atmel-Modul per Hand mit "modprobe <modulname>" nachlädst? (Ausgaben in /var/log/syslog beachten!)
Da ich immer noch nicht weiß, wie das Treibermodul eigentlich heisst, habe ich es einfach mal mit "modprobe atmel" probiert, das nimmt er dann auch kommentarlos hin. /var/log/syslog schweigt dazu. Ich kann nur per lsmod zwei neue Module namens "atmel" und "firmware_class ... used by atmel" sehen.

Duchemin schrieb:
Ich will dir ja den "Spass" an deiner Debian-Installation nicht verderben, aber ich würde mir als Newbie an deiner Stelle wirklich mal Mandrake, SuSE oder Fedora Core anschauen. Die sind wesentlich newbiefreundlicher als Debian und man muss bei weitem nicht so viel Hand anlegen wie bei Debian... (und wenn es doch weiterhin Debian sein sollte, dann entsprechende userfreundliche Distris wie Xandros oder Ubuntu.)
Es ist doch fast geschafft, nur noch dieser dämliche WLAN-Adapter. Dann nur noch das Routing. Dann nur noch Samba. Dann nur noch eine Firewall. *hysterisch lach*

Nauticat33 schrieb:
Hm, ich steige ja ein wenig spät in die Diskussion ein und hab nur diagonal gelesen... Hast du den Kernel-Patch für 2.6er Kernels einkompiliert?
--> http://atmelwlandriver.sourceforge.net/downloads.html
Also auf der Seite steht " To make your usb device functional, using this driver under 2.6 kernels ( < 2.6.8.1 version ), you have to download..." Also nur bei Kernels kleiner als Version 2.6.8.1 und genau den habe ich und sollte damit doch auf der sicheren Seite sein.

Nauticat33 schrieb:
Hast du die wireless-tools aus dem debian-tree mit apt-get installiert? Dann könnten sie vielleicht zu alt sein?

Ansonsten teile ich Duchemins Meinung, daß der Treiber schlicht nicht geladen wird. Hast du den Kernel neu kompiliert und wird auch der richtige Kernel beim Bootvorgang geladen?
Die wireless-tools habe ich per apt-get installiert, also mit Sicherheit nicht die brandheisseste Version. Den Kernel habe ich nicht angerührt, dieser müßte eigentlich alle Voraussetzungen aus der Readme erfüllen.

Als Verzweiflungstat habe ich einfach mal in /etc/network/interfaces folgendes ergänzt:
Code:
iface atml0 inet static
	address 192.168.1.3
	netmask 255.255.255.0
	network 192.168.1.0
	broadcast 192.168.1.255
und per /etc/init.d/networking restart die Änderungen wirksam gemacht. Leider taucht immer noch keine funktionierende amtl0-Schnittstelle unter iwconfig auf. Ich würde ja auch gern nochmal mein Glück mit dem ndiswrapper versuchen, leider ist das Installations-Wiki gerade nicht erreichbar. Danke Euch jedenfalls für die umfangreiche Hilfe.
 

Toff

Bekanntes Mitglied
°ÐrBêÑ° schrieb:
Also auf der Seite steht " To make your usb device functional, using this driver under 2.6 kernels ( < 2.6.8.1 version ), you have to download..." Also nur bei Kernels kleiner als Version 2.6.8.1 und genau den habe ich und sollte damit doch auf der sicheren Seite sein.
Also ich würde dieser Angabe misstrauen. Es gibt keinen 2.6.8.1er Kernel. Höchstens 2.6.8-1 und das wäre die erste Revision eines Distributors. Mein Tip. Hol dir einen Vanilla Kernel (auf deutsch ;) die original Kernel Sourcen) [1], patche ihn [2] und und bau dir mit der alten debian .config deinen Kerlen neu zusammen [3].

Noch was zur .config. In dieser Datei steht die komplette Info wie dein Kernel gebaut wird. In den Debian Kernel Paketen ist diese Datei immer mit enthalten. Sie wird z.b. nach /boot/config-2.6.8-1-686 kopiert. Diese kannst du mit "make menuconfig" einfach nachladen, oder nach /usr/src/linux kopieren.

CU
Toff

[1] http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.9.tar.bz2
[2] http://www.debianforum.de/wiki/KernelsourcenPatchen
[3] http://www.debianforum.de/wiki/?page=Kernel+f%FCr+Debian+Paketsystem+bauen
 

sash

Bekanntes Mitglied
hi drben,

ich habe das was du germacht hast in gleicher form vor.

wie siehts eigentlich mit der geschwindigkeit von mldonkey aus, im vergleich zu emule ?

bin nämlich grad am übelregen ob ich meinen kleinen server unter win oder lin laufen lasse. haupteinsatz ist halt filesharing :)

bitte poste doch mal deine erfahrungen, dieses mozialla plugin find ich auf jedenfall schonmal klasse
 

ÐrBen™

٩(͡๏̯͡๏)۶
@sash: Wie gesagt, der MLDonkey läuft hier hervorragend, seitdem ich auch den (mit eingebauten) Bittorrent-Client nutze, ist die Download-Rate zwar etwas eingebrochen, aber durchschnittlich 74kb/s in den letzten sechs Tagen habe ich mit dem eMule nie erreicht, da waren durchschnittlich maximal 35kb/s drin, bei im Vergleich zum MLDonkey massiven Ressourcenverbrauch. Lass nur größtenteils die Finger von den Standardeinstellungen, nachdem ich daran rumgeschraubt hatte, ging fast gar nichts mehr. Der MLDonkey läuft sehr gut "out of the box".
Auf der anderen Seite ist es manchmal verdammt nervig so eine Linux-Kiste als Anfänger zum Laufen zu bekommen. Ständig fehlt hier etwas oder man weiß dort wieder nicht weiter, jeder kleine Schritt wird zum Krampf. Aber da es mir vor allen Dingen um Stromsparen ging, blieb mir nicht viel anderes übrig als eine "anfängerfeindliche" Konfiguration zu wählen, hauptsache ressourcenschonend. Wenn Dein Server nicht allzu dünn bestückt ist, wäre Windows oder eine andere Linux-Distribution vielleicht stressfreier.

@Toff: Nachdem mein schwachbrüstiger VIA-Prozessor die Nacht durchkompiliert hat, bleibe ich an diesem Schritt aus der Anleitung von http://www.debianforum.de/wiki/?page=Kernel+f%FCr+Debian+Paketsystem+bauen hängen:
Code:
make-kpkg clean
make-kpkg --revision=custom.1.0 --initrd kernel_image

cd ..
dpkg -i kernel-image-2.4.18_custom.1.0_i386.deb  <-- Das klappt nicht
reboot
Ich bekomme immer die Fehlermeldung :
Code:
dpkg: error processing kernel-image-2.6.9_custom.1.0_i386.deb (--install): 
cannot access archive: No such file or directory
Errors were encountered while processing:
 kernel-image-2.6.9_custom.1.0_i386.deb
Ich habe also das "kernel-image-2.4.18..." aus der Anleitung eigenmächtig ersetzt, ich dachte das wäre einfach nur eine von mir zu vergebene Bezeichnung, aber es funkt nicht. Soweit ich das verstanden habe, ist dieser Befehl für die Aktivierung des kompilierten Kernels verantwortlich (Paket wird erstellt?) Was tun?
 

Toff

Bekanntes Mitglied
cannot access archive: No such file or directory
er kann die Datei nicht finden.

a) lief das compilieren ohne fehler durch? Wenn nicht wurde die .db Datei auch nicht erstellt.

Wenn ja:

b) das erzeugte .deb file findest du unter /usr/src

Zum Dateinamen. Klar kannst du denn anpassen. Ist ja wurscht, was für einen Namen die Datei trägt.

CU
Toff
 

ÐrBen™

٩(͡๏̯͡๏)۶
Toff schrieb:
a) lief das compilieren ohne fehler durch? Wenn nicht wurde die .db Datei auch nicht erstellt.

Wenn ja:

b) das erzeugte .deb file findest du unter /usr/src
Uaaaahh, da ist keine .db-Datei. Habe die Kiste wie gesagt nachts durchkompilieren lassen. Da waren am Schluss zwei Fehlermeldungen, irgendwas mit einem Teil von einem Treiber glaub ich. Schmeisse den Compiler jetzt nochmal an und werde dann (höchstwahrscheinlich morgen) die genaue Fehlermeldung posten. Linux stinkt. ;-)

Das ich während des Kompilier-Vorgangs den MLDonkey habe weiterlaufen lassen, war doch nicht falsch, oder?
 

ÐrBen™

٩(͡๏̯͡๏)۶
Okay, der Tux-Schrotthaufen ist fertig. Folgendes hat er beim Kompilieren des Kernels wieder rumzuheulen:

ca. ein Dutzdend mal das hier:
Code:
drivers/char/sx.c: In function ...
warning: passing ... of ... without a cast
Kurz vor Schluss sehr oft das hier:
Code:
drivers/char/drm/gamma_old_dma.h:41: error: structure has no member named 'next_queue'
Und ganz am Schluss dann:
Code:
make[4]: *** [drivers/char/drm/gamma_drv.o] Error 1
make[3]: *** [drivers/char/drm] Error 2
make[2] *** [drivers/char] Error 2
make[1] *** [drivers] Error 2
make[1]: Leaving directory '/usr/src/linux-2.6.9'
make: *** [stamp-build] Error 2
Diesen ganzen Mist habe ich übrigens von Hand abgetippt, weil diese verfluchten Konsolenfenster ums Verrecken kein Copy&Paste unterstützen. :tsts
 

Toff

Bekanntes Mitglied
°ÐrBêÑ° schrieb:
Diesen ganzen Mist habe ich übrigens von Hand abgetippt, weil diese verfluchten Konsolenfenster ums Verrecken kein Copy&Paste unterstützen. :tsts
Dann solltest du mal gpm installieren ;):

# apt-get install gpm

Danach mit der Maus in der Konsole arbeiten, etwas markieren, es gleich in der "Zwischenablage" haben und mit rechten Mausclick wieder einfügen.

Zum restlichen Problem. Hm, versuch den Kernel erstmal ohne den Patch zu compilieren. Ja, ich weiss das geht immer ne weile, aber es ist vielleicht ne Möglichkeit Fehler auszuschliessen.

CU
Toff
 

Gras

Bekanntes Mitglied
°ÐrBêÑ° schrieb:
ca. ein Dutzdend mal das hier:
Code:
drivers/char/sx.c: In function ...
warning: passing ... of ... without a cast
Warnings kannst du ignorieren.

°ÐrBêÑ° schrieb:
Kurz vor Schluss sehr oft das hier:
Code:
drivers/char/drm/gamma_old_dma.h:41: error: structure has no member named 'next_queue'
Den kannst du nicht ignorieren.
Der Fehler bedeutet: im Treiber gamma_old_dma ist ein Fehler im Sourcecode. Per Google habe ich eine Möglichkeit gefunden, den Treiber von der Kompilierung auszuschliessen. [1][2]

Dazu musst du im Verzeichnis des Kernel Sourcecodes die Datei .config bearbeiten, und den Eintrag CONFIG_CLEAN_COMPILE suchen. Dieser sieht vermutlich so aus:
Code:
CONFIG_CLEAN_COMPILE=y
Und du machst daraus:
Code:
#CONFIG_CLEAN_COMPILE
Anschliessend wiederholst du diese Schritte, und solltest dann einen neuen Kernel haben:
Code:
make-kpkg clean 
make-kpkg --revision=custom.1.0 --initrd kernel_image
:)


[1] http://www.linuxquestions.org/questions/history/261295
[2] http://bugme.osdl.org/show_bug.cgi?id=3708
 

ÐrBen™

٩(͡๏̯͡๏)۶
Mannmann. Jede noch so doofe Fehlermeldung paste ich in das Google-Suchfeld von Firefox, aber diese nicht. :o

Auf jeden Fall verstehe ich folgendes nicht: In meiner .config war der Befehl CONFIG_CLEAN_COMPILE schon mit dem Schweinchengatter # auskommentiert, allerdings sah das ganze so aus:
Code:
#CONFIG_CLEAN_COMPILE is not set
Jedenfalls habe ich es dann mit CONFIG_CLEAN_COMPILE = n versucht, da gab es aber wieder die gleichen Schwierigkeiten. Erst als ich wirklich 1:1 das #CONFIG_CLEAN_COMPILE übernommen hatte, lief es (fast) durch. Nach meinem Verständnis werden auskommentierte Zeilen vom Compiler/Interpreter vollständig ignoriert, wie kann dann dort ein Unterschied gemacht werden?
Natürlich hat es natürlich wieder nicht vollständig funktioniert, diesmal hat der Festplattenplatz auf der Linux-Partition nicht ausgereicht, um die -.deb-Datei zu erzeugen. :| Es war auch vorher schon ziemlich knapp, damals habe ich aber per apt-get clean und apt-get autoclean wieder einiges freiräumen können. Auf jeden Fall habe ich jetzt wieder 100% Plattenauslastung auf der Linux-Partition. Gibt es noch eine Möglichkeit, viel Platz zu schaffen? Ansonsten könnte ich auch die Swap-Partition verkleinern (die ich mit 500MB viel zu groß angelegt habe) und die Linux-Partition vergrößern, beide liegen direkt nebeneinander. Ist dies einigermaßen unproblematisch möglich?
 

Gras

Bekanntes Mitglied
°ÐrBêÑ° schrieb:
Auf jeden Fall verstehe ich folgendes nicht: In meiner .config war der Befehl CONFIG_CLEAN_COMPILE schon mit dem Schweinchengatter # auskommentiert, allerdings sah das ganze so aus:
Code:
#CONFIG_CLEAN_COMPILE is not set
Jedenfalls habe ich es dann mit CONFIG_CLEAN_COMPILE = n versucht, da gab es aber wieder die gleichen Schwierigkeiten. Erst als ich wirklich 1:1 das #CONFIG_CLEAN_COMPILE übernommen hatte, lief es (fast) durch. Nach meinem Verständnis werden auskommentierte Zeilen vom Compiler/Interpreter vollständig ignoriert, wie kann dann dort ein Unterschied gemacht werden?
Das verstehe ich auch nicht, auskommentiert ist auskommentiert :confused:

Wegen des Platzproblems, eine Vergrösserung der Linux Partition ist anscheinend dringend nötig, wenn sie bereits 100% hat.
Mit der Änderung einer bestehenden Partition habe ich keine Erfahrung, weiss nicht ob das geht - wird auch vom verwendeten Filesystem abhängen.
Besser wäre es vielleicht, eine neue Partition (ausreichend gross) zu erstellen und diese in /usr, /home oder /var zu mounten.

Als kurzfristige Lösung könntest du mal schauen, ob der gepackte Kernel-Source noch auf der Platte liegt (normalerweise in /usr/src), und die Home-Verzeichnisse kontrollieren, das /root Verzeichnis, die Logfiles in /var/log...
Oder ein paar Esel Downloads abbrechen :fy
 

Toff

Bekanntes Mitglied
Hi DrBen!

Für Linux gibt es parted bzw. qtparted um Partitionen zu bearbeiten. Bin mir jedoch nicht wirklich sicher, ob die auch ohne Datenverlust arbeiten können.

Ansonsten gäbe es noch Partition Magic, das kann angeblich mit ext2/ext3 Partitionen umgehen. Wenn du ReiserFS genommen haben solltest, sieht es wahrscheinlich schlecht aus.

Eine Swap Partition von 500MB ist nicht schlecht gewählt. Normalerweise sagt man zumindest Swap=Ram, oft auch Swap=2xRam.

Wie hast du denn deine Partitionen gewählt?

CU
Toff
 

SeeDyX

Bekanntes Mitglied
ja genau dringend die Log-files in var/log kontrollieren und ggf löschen.

Wenn du die Partitionen verändern wilslt empfehle ich dir ne Boot-CD von Acronis Partition Expert. das kann ohne probleme mit Ext3 und ReiserFS (glaub ich zumindest ;)) umgehn. (mit swap und ext2 sowieso)
das ist zwar jetzt kein freies Linux programm, und es hat Windows XP-Stil, aber ich hatte mit dem prog noch nie problmee und es ist verdammt schnell. Es gibt zwar denk ich mal auch irgendwelche linux tools dafür, aber ich weiß nciht ob ich denen so direkt vertrauen würde...

/Edit: Achja: Partition Magic ist sch**, langsam und kann kein Reiser FS (zumindest bis 8.0 oder so) Ich hab ziemlich lange mit PartitionMagic gearbeitet, war dann aber ziemlich schnell von Partiton Expert überzeugt
 

ÐrBen™

٩(͡๏̯͡๏)۶
Der größte Platzfresser ist das /usr -Verzeichnis, mit einem Verbrauch von 768MB. Nachdem ich im Quellcode-Verzeichnis des 2.6.9er-Kernels ein make-kpkg clean durchlaufen liess, Habe ich nun wieder knapp 200MB frei auf der Linux-Partition. var/logs macht nur 5MB aus.

Also werde ich wieder das CD-ROM-Laufwerk anklemmen und mit Partition Expert hantieren müssen. Hoffentlich geht das gut.

Ich habe die Partitionen im Moment folgendermassen aufgeteilt (80GB-Platte) :

  • /dev/hda3 (Linux) - 1,2 GB, EXT3-Dateisystem
  • Swap-Partition - 512MB (bin von 2x RAM ausgegangen, wird aber höchstens zu 10% ausgelastet, könnte also locker auf 256MB verkleinern)
  • /dev/hda1(Filesharing) - 76GB, FAT32-Dateisystem (will ich später durch umkopieren noch in EXT3 umwandeln, damit der MLDonkey die temporären Download-Dateien nicht gleich in voller Größe anlegt)
 

Toff

Bekanntes Mitglied
Also du warst da ja schon recht geizig. 3GB kannst du doch wohl an Linux abtreten. Hat ja eh keinen Sinn so viel im Share zu haben.

CU
Toff
 

ÐrBen™

٩(͡๏̯͡๏)۶
Es hat alles ohne Komplikationen funktioniert. Unfassbar.

FileShare-Partition verkleinert, Linux-Partition auf 2,5GB vergrößert, Kernel kompiliert und installiert, dabei wurde sogar vollautomatisch ein weiterer Eintrag im Bootmanager (Grub?) für den neuen Kernel erstellt . Und dann den WLAN-Treiber installiert.

Ich habe diesmal aber den Atmel-Alternativ-Treiber von hier verwendet: http://at76c503a.berlios.de/ funktioniert im Moment sehr gut, habe im AdHoc-Modus eine Verbindung zwischen Linux-Server und Notebook hinbekommen.

Nun werde ich am Routing herumpfuschen und versuchen Samba installieren. Ihr könnt also bald wieder mit Hilfeschreien von mir rechnen. ;-)

Vielen Dank an alle, ohne Euch wäre das nicht möglich gewesen. :yo
 

sash

Bekanntes Mitglied
nich schlecht, morgen kommt mein gehöuse und ram, habe mir den Aopen H340H geholt... :D - dann komm ich auch mit hilfeschreien hinzu ;)

mldonkey hab ich erfolgreich installiert, auf ner VMWare... das geht schon ;) Deb - bin auch noch linux noob :D :D
 

sash

Bekanntes Mitglied
so, mein debian sarge mit dem mldonkey läuft nun :)

@drben
benutzt du das script von TOFF ? wenn ja, musstrest du was npassen und kannst du es mir schciken bzw. hier posten ?

@Toff,
kannst du mr mal erklären, wie du dieses script einsetzt - würde es auch gern mit dem cron einrichten... hätte aber gern mal einen bericht von dir, wie das bei dir sozusagen funktioniert.

Danke,


sash
 

Toff

Bekanntes Mitglied
sash schrieb:
so, mein debian sarge mit dem mldonkey läuft nun :)

@drben
benutzt du das script von TOFF ? wenn ja, musstrest du was npassen und kannst du es mir schciken bzw. hier posten ?

@Toff,
kannst du mr mal erklären, wie du dieses script einsetzt - würde es auch gern mit dem cron einrichten... hätte aber gern mal einen bericht von dir, wie das bei dir sozusagen funktioniert.
Aaaalso. Das gepostete Script geht nur für Redhat/Fedora. Ich hab hier eines für Debian gebastelt. Prinzipiell fügt man Startscripte in /etc/init.d hinzu und mit

# update-rc.d meinscript defaults

in die üblichen Runlevel ein.

So, noch was von wegen mldonkey unter debian. Mein Tip:

1.) mldonkey per apt-get installieren. Somit wird auch gleich ein Startscript angelegt, die Files landen in den richtigen Ordnern usw.

# apt-get install mlddonkey-server

2.) Holt euch von Spiralvoice die letzte Version aus dem 2.5.16er Zweig. Gerade aktuell ist die 2-5-16u. Die 2.5.16er Version läuft definitiv deutlich besser als der aktuelle Zweig. Spiralvoice baut auch immer wieder aktuelle Patches ein:

http://ftp.berlios.de/pub/mldonkey/spiralvoice/

3.) Entpackt das Archiv und kopiert *nur* die mlnet Datei nach /usr/bin. Somit habt ihr schon "downgegraded" ;)

4.) Hol dir meine Version des Startscripts:
http://free.pages.at/bucktv/mldonkey-server
-> als /etc/init.de/mldonkey-server speichern

und das dazu passende Configfile:
http://free.pages.at/bucktv/etc.default.mldonkey-server
-> als /etc/default/mldonkey-server speichern

Anpassen müsst ihr nur das Configfile. Aber auch hier müsst ihr nur eure Wunschwerte eintragen. Dieses hat halt noch ein paar Features mehr:
Code:
Usage: /etc/init.d/mldonkey-server {start|stop|restart|force-reload|fast|slow|getnewblocklist}
mit

# /etc/init.d/mldonkey-server fast bzw. slow
könnt ihr zwischen zwei Modi wechseln. Die Werte könnt ihr in der Konfigdatei anpassen. Das solte eigentlich selbsterklärend sein.

# /etc/init.d/mldonkey-server force-reload
bewirkt, dass die Verzeichnisse mit gesharten Dateien neu eingelesen werden. Gut, wenn ihr Files aus dem Share gelöscht/verschoben habt. Somit wird der Speicherplatz auch wirklich freigegeben. Sonst hat mldonkey nämlich immer noch seine Pfoten an der Datei.

# /etc/init.d/mldonkey-server getnewblocklist
holt eine Liste von http://www.bluetack.co.uk, die einige Fake Server, usw enthält. Keine Ahnung obs wirklich was bringt. Aber diese Zeile alle paar Tage per Cron auszuführen tut nicht weh ;)

So, jetzt die Cronjobs. Wenn ihr keine Ahnung von der Crontab habt und euch auch keine Ahnung aneignen wollt, nehmt webmin. Damit geht das Anlegen neuer Cronjobs kinderleicht.

# apt-get install webmin

danach im Broweser https://localhost:10000 eingeben und euch mit eurem root Passwort einloggen. Dann könnt ihr mit Webmin euren Cronjob erstellen (System - Geplante Cron-Aufträge). Stellt die Uhrzeit entsprechend ein. Also die Minuten + Stunden, Tage/Monate/Wochentage sollte wohl auf "Alle" bleiben. Also Befehl dann noch:

/etc/init.d/mldonkey-server KOMMANDO >/dev/null 2>&1

Das schickt die Ausgabe des Skripts in den Müll, solange alles glatt gegangen ist. Wenn nicht bekommt ihr die Ausgabe per Mail.

5.) Hab mir noch ein kleines Miniscript gebaut und dieses unter /usr/bin/dsl-reconnect gespeichert:
Code:
#!/bin/sh
poff
sleep 10
pon
/etc/init.d/mldonkey-server force-reload[/code
Dieses trennt die Verbindung, wartet 10s, baut sie wieder auf und veranlasst mldonkey gleich die Shares neu einzulesen. So kann ich meinen 24h reconnect steuern.

So, viel Spass :D

CU
 Toff
 

sash

Bekanntes Mitglied
Ho Toff,

erstmal VIELEN DANK für deinen MEGA Post... :)

gestern habe ich nochmal den MLDOnkey per apt-get installiert (war vorher schon einmal installiert, von spiralvoice einfach nur in das home verzeichnis vom MLDonkey benutzer)

als es dann per apt-get installiert war habe ich einfach # mlnet im prompt ausgeführt (war auf #/) danach hat der mldonkey alle files direkt auf / angelegt.... anaj das war natürlich super ätzend - daraufhin habe ich heute debian neu installiert... und wieder nur mit dem spiralvoice debian build. soll so nun auch bleiben. :) mit dem apt-get mldonkey-server hab ich genug ;)

das von spiralvoice funzt nun aber ohne probleme. möchte jetzt noch gerne die Scripte einbauen... habe gesehen, das die scripte dafür ausgelegt sind, dass sie auf einem Deb. System mit apt-get version laufen, ist doch richtig oder ?

ich möchte nun aber gern mein mldonkey benutzen, der im /home/mldonkey/mldonkey installiert ist... muss ich nur die PFADE ändern also

von:
PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
WRAPPER=/usr/bin/mldonkey_server
NAME=mlnet
DESC="MLDonkey"
CONFIG=/etc/default/mldonkey-server
PIDFILE=/var/run/mldonkey/$NAME.pid

auf
PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
WRAPPER=/home/mldonkey/mldonkey
NAME=mlnet
DESC="MLDonkey"
CONFIG=/home/mldonkey/mldonkey


Was mache ich mit dem Eintrg "PIDFILE" ?

Sorry für meine fragen, habe erst vor ca. 2 Wochen mit Linux angefangen... :D

greetz,

SaSh
 

Slayer

Bekanntes Mitglied
sash schrieb:
Was mache ic mit dem Eintrg "PIDFILE" ?
Ich kenne mldonkey zwar nicht, aber ich vermute einfach mal aus dem Bauch heraus, dass Du hier angibst, wo mldonkey das PID-File ablegen soll. In dieser Datei steht die Prozess ID, die das Programm benutzt, wenn es aktiv ist. Wird es beendet, wird das File gekillt. Die laufenden Prozesse kannst Du mit ps -A sehen.
~Slayer
 

Toff

Bekanntes Mitglied
sash schrieb:
...daraufhin habe ich heute debian neu installiert...
Lol, typisch Windowsler ;) Sorry, keine Beleidigung ;P

Einfaches löschen von ein paar Files (notfalls anhand des Erstellungsdatums) hätte es auch getan).

Slayer hat es schon richtig erklärt. Das Pid file enthält nur die Process ID des laufenden Priogramms. Der Pfas passt schon. Trotzdem würde ich dir empfehlen die Installation "the Debian way" zu machen. Hat definitiv Vorteile, da alles an seinem angestammten Platz bleibt.

Du startest apache ja auch nicht einfach per /usr/bin/apache & usw. Lässt du eventuell mldonkey noch als root laufen?!? Das wäre wirklich nicht gerade (sorry) clever.

Daher, setz dich einmal auf deinen Hosenboden und richte es richtig ein, und gut ist :)

CU
Toff
 

sash

Bekanntes Mitglied
eigentlich hab ich extra einen benutzer mldonkey erstellt. und den im mld eingetragen... dann sollte dies doch darunter laufen... wenn ich top eingebe steht da ja auch mldonkey :)

soweit so gut.... aber gestern konnt oich halt in jedem pfad, also egal wo ich mich befinde mlnet eingeben unjd er hat da, wo ich mlnet eingeben hab die config incoming dirs etc pp angelegt.... :) das fand ich schon super ätzend, dafpr gibts doch die deb ordner oder nicht ?°?° irgendwas scheint da schiefgelaufen zu sein, denk ich mal :D bin ja auch noch kein profi...


da mir dann das so vorkam als ob ein chaos vorhersch, hab ich natpürlich sofort neu installiert und 4 stunden gebraucht wieder alles einzurichten ---- muss ja für alles im inet noch nachschauen ;)

woran lag es, das wenn ich mlnet ausführe, in dem aktuellen pfad dann alles abgelegt wird ? oder hätt ich den mld besser anders starten sollen, als mir mlnet ??

sorry ;) aber bin nur win profi und linux noob :) aber ich beschäftige mich mit der materie .... eine leistung für mich war heut ja auch schon wieder "screen" hinzubekommen sodass nur 1 Rechner immer läuft ;) am linux echner ist nun nichts mehr ausser nem lan und stromabel dran ;)
 

Toff

Bekanntes Mitglied
sash schrieb:
woran lag es, das wenn ich mlnet ausführe, in dem aktuellen pfad dann alles abgelegt wird ? oder hätt ich den mld besser anders starten sollen, als mir mlnet ??

sorry ;) aber bin nur win profi und linux noob :) aber ich beschäftige mich mit der materie .... eine leistung für mich war heut ja auch schon wieder "screen" hinzubekommen sodass nur 1 Rechner immer läuft ;) am linux echner ist nun nichts mehr ausser nem lan und stromabel dran ;)
ja :)

Dienste startet man mit den init scripten also

/etc/init.d/mldonkey-server start

genauso wie

/etc/init.d/samba start usw...

Und falls du mal halbwegs mit deiner Linux Installation zufrieden bist. Es gibt auch Disk Images für Linux. Also entweder Knoppix starten und partimage verwenden. Oder Acronis True Image kommt auch mit allen gängigen Linux Paritionen zurecht.

CU
Toff
 

ÐrBen™

٩(͡๏̯͡๏)۶
Hier bin ich wieder. Eine Weile lang lief alles wirklich toll, konnte Squid als Proxy installieren und kann nun endlich gemütlich per WLAN und Notebook überall in der Bude ins Web. Aber dann kam Samba...

Habe Samba per apt-get install draufgekloppt und Webmin von Hand installiert. Benutzer angelegt, Freigabeverzeichnis bestimmt, aber ich bekomme ums Verrecken keine Verbindung hin. Jedesmal wenn ich mich per "Netzlaufwerk verbinden" mit dem in Samba freigegebenen Verzeichnis verbinden will, poppt eine Kennwortabfrage auf, soweit ja auch normal. Wenn ich aber nun die in Samba hinterlegten Benutzerdaten eingebe, z.B. als Benutzer: "Notebook", poppt sofort danach das Loginfenster erneut auf und der Benutzername wurde durch MEINRECHNERNAME/Notebook ersetzt. Dann kann ich tausendmal auf OK klicken, das Fenster erscheint einfach immer wieder. Das gleiche passiert mit beliebigen anderen Benutzer/Passwort-Kombinationen.

Was ist da kaputt? Netzwerkverbindung steht, Samba + Notebook sind in der gleichen Arbeitsgruppe, ich kann in der Netzwerkumgebung auch meinen Linux-Server sehen. Ich habe auch schon versucht, den Windows-Benutzernamen + -Passwort mit den Sambaeinstellungen gleichzusetzen, aber Pustekuchen.
 

Toff

Bekanntes Mitglied
So, erstmal kurz zur /etc/samba/smb.conf. Hier nur der Ausschnitt aus der [global] section. Die Shares sollten eigentlich selbsterklärend sein.
Code:
[global]
workgroup = hiertragichmeinearbeitsgruppeein
server string = %h Samba Server
hosts allow = 192.168.0.
printcap name = cups
load printers = yes
printing = cups
guest account = nobody
log file = /var/log/samba/%m.log
max log size = 50
security = user
encrypt passwords = true
smb passwd file = /etc/samba/smbpasswd
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
local master = yes
os level = 65
domain master = yes
preferred master = yes
wins support = yes
dns proxy = no
Wichtig ist security=user, nur als Beispiel das "Home" Share:

Code:
[homes]
comment = Home Directories
browseable = no
writable = yes
valid users = %S
create mode = 0664
directory mode = 0775
So, was man wissen muss, ist das Samba nicht die Linux User kennt, sondern seine Nutzer selber verwaltet. Hat man also mal mit

# adduser waldemar

den User waldemar angelegt, so muss man ihn auch noch im Samba Server anlegen. Wichtig ist, dass du den gleichen Usernamen und das gleiche Passowert, wie auf deiner Windowskiste nimmst.

# smbpasswd -a waldemar

Nochwas zum Thema Dateisysteme.

Ich würde euch für die Parition auf der die temp Dateien liegen ReiserFS als Betriebsystem empfehlen. Ext3 scheint durch die vielen Schreibvorgänge und die dadurch grossen Journalingeinträge irgendwie "vollzumüllen".

Man kann das hier sehr schön an diesem Graphen erkennen:



Die Linie kennzeichnet den Umstieg von Ext3 auf ReiserFS. Die Dateien sind zwischendurch auf die "volle" Grösse angewachsen, da ich sie auf eine NTFS verschoben hatte, um neu formatieren zu können. Aber man sieht schön, bei ext3 wird nach dem löschen einer Datei aus dem Share nicht wieder der komplette Speicherplatz freigegen. Keine Ahnung warum.

CU
Toff
 

ÐrBen™

٩(͡๏̯͡๏)۶
Habe es immer noch nicht gebacken gekommen. :-(

Ich habe den Verdacht, das Problem liegt bei dem Ordner, den ich für den WinXP-Client freigeben möchte. Es handelt sich um eine gemountete FAT32-Partition (den MLDonkey FileShare, /windows). Das Problem ist, daß ich in der Konsole nur als root (dem Besitzer des Ordners) in den Ordner komme. Mit dem Linux-Benutzernamen, der auch als Samba-User eingerichtet ist, kann ich nicht in den Ordner wechseln. Und das obwohl bei dem Ordner für die relevante Gruppe und "Andere" immerhin Leserechte vergeben sind. Die Rechte ändern funktioniert nicht, ich nehme an, weil es eine FAT32-Partition ist.

Habe es dann nochmal mit dem Eintrag "security = share" und "public = yes" in der sambaconfig versucht, dann kann ich immerhin sogar den freigegebenen Ordner in der Netzwerkumgebung sehen. Will ich diesen öffnen, poppt wieder ein Anmeldefenster auf, dort ist als Benutzername unveränderlich "MEINLINUXSERVERNAME\Gast" eingetragen. Egal welches Passwort ich eingebe, dieses Fenster schliesst sich nicht.

Was habe ich nur versaut?

edit: Hier meine aktuelle SambaConfig, bei der ich versucht habe, Zugriff ohne Authentifizierung zu erlangen:
Code:
[global]
	hosts allow = 192.168.1.
	log file = /var/log/samba/log.%m
	passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n .
	socket options = TCP_NODELAY
	encrypt passwords = true
	smb passwd file = etc/samba/smbpasswd
	security = share
	passdb backend = tdbsam guest
	passwd program = /usr/bin/passwd %u
	dns proxy = no
	guest account = nobody
	server string = %h server (Samba %v)
	path = /windows
	default = FileShare
	workgroup = Tuxstinkt
	os level = 20
	syslog = 0
	panic action = /usr/share/samba/panic-action %d
	max log size = 50


[FileShare]
	comment = FileShare-Platte
	writeable = yes
	valid users = notebook, test
	public = yes
	path = /windows
Vielen Dank nochmal für den Filesystem-Typ, werde mich bei der Konvertierung dran halten.
 

Gras

Bekanntes Mitglied
Drei Dinge, die mir einfallen:
- wenn der User schon unter der Konsole nicht auf die Partition zugreifen kann, solltest du das zuerst klären. Wie sieht der Eintrag in der /etc/fstab für /windows aus? Um in einen Ordner zu kommen, benötigst du ausserdem das "x" Recht - du schriebst nur vom "l" Recht.
- in der Samba Config hast du bei der Direktive "smb passwd file" den Slash vor dem Pfad vergesesen - findet Samba dein Password File nicht?
- Samba weigert sich mit Absicht, bei dem Workgroup Name :lol

Wenn das alles nicht hilft, Loglevel bei Samba hochschrauben (-> manpages) und Logs prüfen/posten!
 

sash

Bekanntes Mitglied
Hallo,

habe jetzt die tage den 16er MLD laufen lassen, nun den 25(?)er ... muss feststellen, das der 25er viel viel mehr sourcen findet, wie der 16er, ist da sbei euch auch so ?


muss sagen das der windows emule und der windows Bittorrent noch sehr viel besser gesaugt haben..... habt ihr noch ein paar tipps ? Bin nämlich schon fast wieder am überlegen uf windwos umzustellen...

und noch was anderes:

ist auf dem Standard Linux Kernel, der bei Debian Sarge dabei der HLT Befehl dabei, also wird er genutzt ?

Dank,

Sash
 

ÐrBen™

٩(͡๏̯͡๏)۶
@sash: Ich habe nur die 16er am Laufen, weil die rennt ganz gut bei mir. Der Bittorrent-Client vom MLDonkey ist tatsächlich nicht so der Bringer, er läuft zwar, aber eben nicht so schnell wie ich es von Azureus gewohnt bin. Ist aber noch im Rahmen, nutze BT auch eher selten. Das ed2k-Netzwerk läuft bei mir in der Default-Konfig hervorragend, aber nur wenn ich wirklich mind. 40 Files parallel ziehe. Wenn ich so wie im Moment nur zwei Downloads aktiv habe (Platte voll :mrgreen: ) dann plätschern diese auch nur mit 12kb/s dahin.

@Gras: Ich habe jetzt mal testweise einen Ordner auf meine Linux-Ext3-Partition per Samba freigegeben, der mit "jeder darf alles"-Rechten ausgestattet ist, gleicher Fehler wie oben beschrieben.

Schaue gerade die Logfiles durch, hätte wohl nicht gleich den Debug-Level auf 10 hochschrauben dürfen, bisschen viel Text. Aufgefallen ist mir die Fehlermeldung:
Code:
check_ntlm_password: sam authentication for user [notebook] FAILED with error NT_STATUS_WRONG_PASSWORD
Also ist es wohl ein Passwort-Problem.

Immerhin bin ich gerade auf das freigegebene ext3-Verzeichnis mit "security=share" und leerem Passwort gelangt, was für ein Erfolgserlebnis.
 

Toff

Bekanntes Mitglied
Hm, ich lass mein Samba immer mit

security = user

unter [global] laufen und habe hier nicht derartige Probleme, wie du. Vielleicht solltest du mal dies umstellen.

Ausserdem sind deine Zeilen

passdb backend = tdbsam guest
passwd program = /usr/bin/passwd %u

imho nicht korrekt. Schau dir einfach nochmal meine Konfig an. Da steht eigentlich alles korrekt drinnen.

CU
Toff
 

ÐrBen™

٩(͡๏̯͡๏)۶
Toff schrieb:
Ausserdem sind deine Zeilen

passdb backend = tdbsam guest
passwd program = /usr/bin/passwd %u

imho nicht korrekt. Schau dir einfach nochmal meine Konfig an. Da steht eigentlich alles korrekt drinnen.
Habe die beiden Zeilen gerade mal auskommentiert, immer noch gleiches Spiel wie oben beschrieben. Es läuft im Moment nur mit "security = share" und dem Gastzugang. Die beiden von Dir erwähnten Zeilen wurden, soweit ich mich erinnern kann, während der Samba-Installation erklärt. Dort wurde ich zu irgendwas im Stil von "es wird absolut empfohlen das zu tun, ist viel sicherer" gedrängt. Im Moment ist mein Netzwerk sowieso ein einziges riesiges Sicherheitsloch, habe nicht mal die WLAN-Verschlüsselung aktiviert (gibt der Treiber nicht her). Für die VPN-Installation fehlen mir im Moment die Nerven.
 
Oben Unten